Ana içeriğe geç
Yardım

Güncel sürümün sahibi: Peter Wood ,

Başlık:

Why did fan stop working after LCD panel repair?

Metin:

I just performed a replacement of the LCD panel in my Macbook Core 2 Duo (Penryn). The LCD works great and all the other systems are performing normally. However, when the system gets hot, the fan does not kick in. Eventually the system overheats and shuts down. I installed smcFanControl, and it doesn't do anything to affect the fan. In fact, it shows a fan speed of '000.' This makes me think that something happened to the fan in the process of disassembly/reassembly. I have disassembled again to check on the fan. Disconnecting it wasn't part of the repair, so I hadn't purposely disconnected it, and I verified that the cable was still properly seated. I reseated it for good measure. I checked and there was nothing blocking the fan. Reassembled and fan still would not turn on.

When I was doing the original repair, I had clipped the alligator clip of my anti-static strap onto one of the metal bits of the fan. My thought is that perhaps the strap discharged some static into the fan, or the clip damaged it somehow. Visually it looks fine.

Any thoughts?

Cihaz:

MacBook Core 2 Duo

Durum:

open

Kabul Edilen Cevap:

124602

Orijinal gönderinin sahibi: Peter Wood ,

Başlık:

Why did fan stop working after LCD panel repair?

Metin:

I just performed a replacement of the LCD panel in my Macbook Core 2 Duo (Penryn). The LCD works great and all the other systems are performing normally. However, when the system gets hot, the fan does not kick in. Eventually the system overheats and shuts down. I installed smcFanControl, and it doesn't do anything to affect the fan. In fact, it shows a fan speed of '000.' This makes me think that something happened to the fan in the process of disassembly/reassembly. I have disassembled again to check on the fan. Disconnecting it wasn't part of the repair, so I hadn't purposely disconnected it, and I verified that the cable was still properly seated. I reseated it for good measure. I checked and there was nothing blocking the fan. Reassembled and fan still would not turn on.

When I was doing the original repair, I had clipped the alligator clip of my anti-static strap onto one of the metal bits of the fan. My thought is that perhaps the strap discharged some static into the fan, or the clip damaged it somehow. Visually it looks fine.

Any thoughts?

Cihaz:

MacBook Core 2 Duo

Durum:

open