Ana içeriğe geç
Yardım

Güncel sürümün sahibi: oldturkey03 (oy detayları) ,

Başlık:

Magsafe behaving like power button

Metin:

My macbook is behaving rather funny since a few weeks:

When plugged in, the macbook functions perfectly like it should. It charges the battery, powers on and off.

When the magsafe connector is disconnected though, the problems start: immediately after disconnecting, the shutdown menu shows up in OS X, like when pressing the power button. After 5 seconds, the macbook just powers off like when the power button is held.

When trying to power up when the magsafe cable is not connected, the power button just doesn't respond. It only works when the cable is connected.

The battery has been diagnosed by the local apple reseller as being in very good condition, so i think that the battery is not the problem(the shutdown dialog in osx when disconnecting is the regular one, not the low battery one.)

I have already tried the usual tricks like PRAM and NVRAM reset. I also tried an other magsafe cable, but this did not solve the problem

Does anyone have a clue what might be causing these problems? Magsafe board? Power button? Logicboard?

Cihaz:

MacBook Pro 13" Unibody Late 2011

Durum:

open

Kabul Edilen Cevap:

146396

Düzenleyen: originalmachead ,

Başlık:

Magsafe behaving like power button

Metin:

My macbook is behaving rather funny since a few weeks:

When plugged in, the macbook functions perfectly like it should. It charges the battery, powers on and off.

When the magsafe connector is disconnected though, the problems start: immediately after disconnecting, the shutdown menu shows up in OS X, like when pressing the power button. After 5 seconds, the macbook just powers off like when the power button is held.

When trying to power up when the magsafe cable is not connected, the power button just doesn't respond. It only works when the cable is connected.

The battery has been diagnosed by the local apple reseller as being in very good condition, so i think that the battery is not the problem(the shutdown dialog in osx when disconnecting is the regular one, not the low battery one.)

I have already tried the usual tricks like PRAM and NVRAM reset. I also tried an other magsafe cable, but this did not solve the problem

Does anyone have a clue what might be causing these problems? Magsafe board? Power button? Logicboard?

Cihaz:

MacBook Pro 13" Unibody Late 2011

Durum:

open

Orijinal gönderinin sahibi: Allard ,

Başlık:

Magsafe behaving like power button

Metin:

My macbook is behaving rather funny since a few weeks:

When plugged in, the macbook functions perfectly like it should. It charges the battery, powers on and off.

When the magsafe connector is disconnected though, the problems start: immediately after disconnecting, the shutdown menu shows up in OS X, like when pressing the power button. After 5 seconds, the macbook just powers off like when the power button is held.

When trying to power up when the magsafe cable is not connected, the power button just doesn't respond. It only works when the cable is connected.

The battery has been diagnosed by the local apple reseller as being in very good condition, so i think that the battery is not the problem(the shutdown dialog in osx when disconnecting is the regular one, not the low battery one.)

I have already tried the usual tricks like PRAM and NVRAM reset. I also tried an other magsafe cable, but this did not solve the problem

Does anyone have a clue what might be causing these problems? Magsafe board? Power button? Logicboard?

Cihaz:

MacBook Pro 13" Unibody Late 2011

Durum:

open