Ana içeriğe geç
Yardım

Güncel sürümün sahibi: Dan (oy detayları) ,

Başlık:

Can't power on without SMC reset and help from another MacBook

Metin:

Grabbed out my old unused White Macbook 13" Mid 2009 (Macbook 5,2) because I'd like to donate it to someone. However, it wouldn't power on or charge (no light on the MagSafe adapter).

I worked out that if I first connect the MagSafe adapter to another Macbook (a 13" Macbook Pro) and then plug it into the 13" White Macbook the green light turns on with White Macbook 13". So it would seem that the White Macbook isn't completing the handshake but the MagSafe adapter works for a while after the handshake is completed on another Mac. This is all 100% reproducible.

Anyway, the Macbook still wouldn't turn on (and the MagSafe indicator remains green - never orange). So I worked out that if I SMC reset, the Macbook will then proceed to boot. However, when booted it said "No battery connected" and the fans remain on high power constantly (i.e. the kind of stuff an SMC reset is supposed to fix).

If I turn the computer off it then won't boot again. I have to repeat the procedure i.e. MagSafe handshake with another Mac, then SMC reset and it boots.

I pulled apart the Macbook detached the MagSafe connector and cleaned some gunk off it. I then replaced the hard-drive with a brand new SSD that has Yosemite installed (instead of Lion). I then gave everywhere else inside and out a clean and reassembled. However, after reassembling the same problem persisted (SMC reset needed before booting).

After several SMC resets and boots, I've now got the Macbook in another state. The power is connected but there is no light at all on the MagSafe. However, the computer boots up. When booted fans are on again, but no power indicator of any sort is in my status bar (no battery, no DC power thunderbolt either). Disconnecting the power instantly turns the Mac off, so clearly it's really running off DC power.

The Macbook is running the latest firmware/SMC. When booted up everything actually functions fine aside from the fan - I'm typing on the Mac now.

Does anyone have any suggestions as to what could be wrong, tests to diagnose or ideally a solution? I'm reasonably handy with a multimeter so if anyone has some power diagnosis steps then I can follow along easily enough.

Cihaz:

MacBook Core 2 Duo

Durum:

open

Kabul Edilen Cevap:

227617

Düzenleyen: Dan ,

Başlık:

Can't power on without SMC reset and help from another MacBook

Metin:

Grabbed out my old unused White Macbook 13" Mid 2009 (Macbook 5,2) because I'd like to donate it to someone. However, it wouldn't power on or charge (no light on the MagSafe adapter).
Grabbed out my old unused White Macbook 13" Mid 2009 (Macbook 5,2) because I'd like to donate it to someone. However, it wouldn't power on or charge (no light on the MagSafe adapter).
 
I worked out that if I first connect the MagSafe adapter to another Macbook (a 13" Macbook Pro) and then plug it into the 13" White Macbook the green light turns on with White Macbook 13". So it would seem that the White Macbook isn't completing the handshake but the MagSafe adapter works for a while after the handshake is completed on another Mac. This is all 100% reproducible.
 
Anyway, the Macbook still wouldn't turn on (and the MagSafe indicator remains green - never orange). So I worked out that if I SMC reset, the Macbook will then proceed to boot. However, when booted it said "No battery connected" and the fans remain on high power constantly (i.e. the kind of stuff an SMC reset is supposed to fix).
 
If I turn the computer off it then won't boot again. I have to repeat the procedure i.e. MagSafe handshake with another Mac, then SMC reset and it boots.
 
I pulled apart the Macbook detached the MagSafe connector and cleaned some gunk off it. I then replaced the hard-drive with a brand new SSD that has Yosemite installed (instead of Lion). I then gave everywhere else inside and out a clean and reassembled. However, after reassembling the same problem persisted (SMC reset needed before booting).
 
After several SMC resets and boots, I've now got the Macbook in another state. The power is connected but there is no light at all on the MagSafe. However, the computer boots up. When booted fans are on again, but no power indicator of any sort is in my status bar (no battery, no DC power thunderbolt either). Disconnecting the power instantly turns the Mac off, so clearly it's really running off DC power.
 
The Macbook is running the latest firmware/SMC. When booted up everything actually functions fine aside from the fan - I'm typing on the Mac now.
 
Does anyone have any suggestions as to what could be wrong, tests to diagnose or ideally a solution? I'm reasonably handy with a multimeter so if anyone has some power diagnosis steps then I can follow along easily enough.

Cihaz:

White Macbook 13" Mid 2009MacBook Core 2 Duo
White Macbook 13" Mid 2009MacBook Core 2 Duo

Durum:

open

Orijinal gönderinin sahibi: Benjamin Dobell ,

Başlık:

Can't power on without SMC reset and help from another MacBook

Metin:

Grabbed out my old unused White Macbook 13" (Macbook 5,2) because I'd like to donate it to someone. However, it wouldn't power on or charge (no light on the MagSafe adapter).

I worked out that if I first connect the MagSafe adapter to another Macbook (a 13" Macbook Pro) and then plug it into the 13" White Macbook the green light turns on with White Macbook 13". So it would seem that the White Macbook isn't completing the handshake but the MagSafe adapter works for a while after the handshake is completed on another Mac. This is all 100% reproducible.

Anyway, the Macbook still wouldn't turn on (and the MagSafe indicator remains green - never orange). So I worked out that if I SMC reset, the Macbook will then proceed to boot. However, when booted it said "No battery connected" and the fans remain on high power constantly (i.e. the kind of stuff an SMC reset is supposed to fix).

If I turn the computer off it then won't boot again. I have to repeat the procedure i.e. MagSafe handshake with another Mac, then SMC reset and it boots.

I pulled apart the Macbook detached the MagSafe connector and cleaned some gunk off it. I then replaced the hard-drive with a brand new SSD that has Yosemite installed (instead of Lion). I then gave everywhere else inside and out a clean and reassembled. However, after reassembling the same problem persisted (SMC reset needed before booting).

After several SMC resets and boots, I've now got the Macbook in another state. The power is connected but there is no light at all on the MagSafe. However, the computer boots up. When booted fans are on again, but no power indicator of any sort is in my status bar (no battery, no DC power thunderbolt either). Disconnecting the power instantly turns the Mac off, so clearly it's really running off DC power.

The Macbook is running the latest firmware/SMC. When booted up everything actually functions fine aside from the fan - I'm typing on the Mac now.

Does anyone have any suggestions as to what could be wrong, tests to diagnose or ideally a solution? I'm reasonably handy with a multimeter so if anyone has some power diagnosis steps then I can follow along easily enough.

Cihaz:

White Macbook 13" Mid 2009

Durum:

open