Skip to main content

Original post by: khaledatti ,


Alright I went ahead and tried the reset for 1 minute and I had no luck. There has been some weird things happening and I need to describe them.

First off when  I remove the battery and power cycle the MBP by holding for 10 seconds plug it in and then continue holding for 10 and then press the power button again it turns on. It starts and connects to the internet and everything. This is without a battery. When I went to overview though it still reads the memory as 4gb instead of the new 16gb. I tried shutting down and starting with the battery in it this time and it didn't work. I even tried an SMC reset and all that fancy shmancy stuff.

Then I was kind of getting upset so I powercycled it again and while it was on and working I plugged the new battery in. All of a sudden the fan sped up and was making much more noise. The computer obviously wasn't detecting the battery and said the charge was at 0%. Also in the same fashion there wasn't a battery indicator at the top menu bar beside the WIFI. I decided to take things a step forward and unplug the charger, to see if the battery was working. Because if the computer continued to run on the battery then there has to be some dumb miscommunication or something stupid going on. When I unplugged the AC adapter viola, the computer stayed on with the battery plugged in. Now the crazy part is that I shut it down and restarted it almost 3-4 times and it was fully running on the battery. Yet it still didn't detect the ram and also continued to say 0% charge.

let me know what you think because I'm a PC guy, this is for my wife and its getting crazy up in here.