Skip to main content
Help

Current version by: James Lloyd ,

Title:

iPhone 7 stuck on apple logo after screen replacement

Text:

I first replaced the screen and got a boot loop error.

When I connected the old, broken screen it worked fine and booted properly, so thought it was the new screen that was faulty.

I ordered another replacement screen and did the replacement but afterwards the setup just stayed on the apple logo indefinitely. I thought this screen was faulty as well so reconnected the original broken screen but the same thing was happening with that.

I read through a few forums saying it may be the camera flex cable that is broken, so I disconnected that and there was no change, still staying on the apple logo.

I have now bought another camera flex cable to double-check if that’s what is causing the error (I may have broken it during one of the replacements), but no success.

Cihaz:

iPhone 7

Durum:

open

Accepted Answer:

561169

Edit by: James Lloyd ,

Title:

iPhone 7 stuck on apple logo after screen replacement

Text:

I first replaced the screen and got a boot loop error.

When I connected the old, broken screen it worked fine and booted properly, so thought it was the new screen that was faulty.

I ordered another replacement screen and did the replacement but afterwards the setup just stayed on the apple logo indefinitely. I thought this screen was faulty as well so reconnected the original broken screen but the same thing was happening with that.

I read through a few forums saying it may be the camera flex cable that is broken, so I disconnected that and there was no change, still staying on the apple logo.

I have now bought another camera flex cable to double-check if that’s what is causing the error (I may have broken it during one of the replacements), but no success.

Cihaz:

iPhone 7

Durum:

open

Accepted Answer:

561169

Original post by: James Lloyd ,

Title:

iPhone 7 stuck on apple logo after screen replacement

Text:

I first replaced the screen and got a boot loop error.

When I connected the old, broken screen it worked fine and booted properly, so thought it was the new screen that was faulty.

I ordered another replacement screen and did the replacement but afterwards the setup just stayed on the apple logo indefinitely. I thought this screen was faulty as well so reconnected the original broken screen but the same thing was happening with that.

I read through a few forums saying it may be the camera flex cable that is broken, so I disconnected that and there was no change, still staying on the apple logo.

I have now bought another camera flex cable to double-check if that’s what is causing the error (I may have broken it during one of the replacements), but no success.

Cihaz:

iPhone 7

Durum:

open