Ana içeriğe geç
Yardım

Orijinal gönderinin sahibi: dub0076 ,

Metin:

The '''++solution which worked++''' for me was... opening the motor pump, clean the motor magnet section, reconnect and there we go.

For me, what happened is this:

*    The dishwasher stopped heating

*    The heating element was still good, reading 13 ohms.  Which also lead me to believe the thermostat was ok or else I could, potentially, have read an open circuit, or infinite resistance.

*    But for some reason, the heating element electronic relays on the controller board were never kicking into the conductive state, therefore not providing the 120VAC needed for heating.

At that point, I thought it was a controller board issue.  So I changed it, for the "small" price of 345$.  When I changed it, the heat starting working again and I thought I had discovered and solved the issue, only to find out it had come right back a couple of days after.

Through reading on the web, I found out on the Tech Manual that when the controller board detects an issue while heating, it goes into an error state that prevents the relays from feeding the 120VAC to the heating element in the dishwasher.  The controller board remains in that state until the error code is acknowledged and cancelled by the user.

On my dishwasher model (Whirlpool WDT910SSY3), using three consecutive buttons (whichever the ones you select, doesn’t matter), you follow the sequence 1-2-3, 1-2-3, 1-2-3.  The dishwasher goes into a tech sequence with many steps (25 in my case).  Once you’re done with it, you can acknowledge the codes, which resets them.

Once I had cleared the error code, the heating relays started kicking again and everything worked has intended immediately (for the heating part anyway).  What I figured is that the new controller board I had bought, received and installed was more than likely not in an error state at installation time.  Explaining why it worked a couple of times at first, only to go back into the trouble, since the actual issue was still there.

B-U-T!!!!! While troubleshooting, I found out that my motor pump was only working intermitently. When a washing sequence was starting, I could hear the water valve open and fill up the dishwasher and then, nothing for a while.  The motor pump was supposed to start spinning but it wasn’t.  So I taped on the motor pump a bit to suddenly hear it start spinning.

So I simply dismantled the motor pump (very easy procedure in my case), to find out that the somewhat sealed internal part where the magnet turns was so dirty that pieces of food were literally sticking to the magnet, making the whole fan shaft part unbalanced and shake like a washing machine trying to spin  with all the clothes on the same side of the drum.

So I cleaned everything, put some non-toxic mineral oil in the little gromet where the shaft goes in to help the motor turn and... VOILA!!!!  It's been working fine for weeks now.

So before you spend, find out how to get the error codes on your machine, clear them, clean the whole dishwasher, including the motor pump assembly, reconnect and try.

Hope it helps.

Durum:

open