Batteries not charging, Everything else works

Good Evening,

I have a 17" PowerBook G4 1.67 GHz machine. I have two batteries for it, one NewerTech that I purchased new about a year ago (and haven't used much), the other is the original Apple battery that only gives about an hour of life.

My problem, in a nutshell, is that neither battery charges.

When I plug in the power adapter, I get the green ring for a few seconds, then it turns amber to indicate that it's charging. But the percentage of charge shown in the menu bar doesn't go up. Neither do the indicator lights on the battery. The computer turns on and runs fine when plugged into the power adapter.

I've tried resetting the PMU, with no change in results.

This computer did charge when I got it, but somewhere along the line that stopped working. I suspect a hardware problem.

Any suggestions? If it's hardware, what part do I need to be looking at?

Thanks.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

I woudl replace the battery connector: G4 Aluminum 17" Battery Connector

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

Thanks for the suggestion. Unfortunately, replacing that part didn't fix the problem. Judging by the fact that the connector plugs into the motherboard, am I now looking at replacing the MB?

tarafından

Yorum Ekle

Yanıtını ekle

Ed Heckman sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 1

Her zaman: 479