Ana içeriğe geç

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1469 Soru Tümünü görüntüle

Can't reinstall HDD or New SSD

I removed my HDD (Toshiba 80GB) the other day getting ready to install a new SSD and put it (the Tosh) back in until I was totally ready for the new install. Today, I removed the HDD again and tried to install my new Crucial M4 128GB SSD. It wouldn't go all the way in. And now the old HDD won't go back in either.

Peering into the drive bay with a flashlight, it looks like some kind of rubberized strip/gasket has been loosened and is preventing the drives from seating properly. I looked at the tear-down for the hard drive connector and this item I see doesn't appear to be that, but I guess it could be. If there is a shorter solution than going through the 18 steps to get to the connector, I'd sure like to know it. It just seems to me that if the connector is secured with two screws it shouldn't have come loose from just removing the drive.

Any suggestions? TIA

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

MacBook Pil Tamir Setleri

Başlangıç $69.99

Buy Now

MacBook Pil Tamir Setleri

Başlangıç $69.99

Buy Now

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hi Bob,

If you already had a look and there is something loose, it seems that stripping down your mac will be the way to go. Now, you do not need to go all the 18 steps. Why dont you try until step 12. That will take you to not having the upper case and granting you a much better view of what could be preventing the drives to slide into position. This will also allow you to assess if you need to go until step 18 or not.

Keep us posted.

MacBook Core 2 Duo Hard Drive Replacement

Bu yanıt yardımcı oldu mu?

Puan 3


Thanks, Jay. Seems my original project to get more life out of this laptop keeps running into roadblocks. Now I need to buy a new set of Phillips screwdrivers besides the torx set I got yesterday. I also made an appointment with the Apple Genius bar for this morning to get a 2nd opinion. I'll let you know.

I need to give props to the Crucial customer service rep who spent close to an hour on the phone with me trying to figure out why the connection ends of the SSD did not match the Toshiba HDD I removed. We thought that was the problem until I discovered the piece in the bay.

The interesting part of all this is that I removed the HDD a few days ago, shook it gently a bit and slid it back in. The MacBook worked fine for its usual 10-15 minutes then crapped out, as usual. But the drive fit perfectly then. It was after removing it a 2nd time and trying to insert the SSD that problems started.


Let us know what the guys at the Genius Bar said.


Snow Leopard is now loading on the MacBook. The Genius took the liberty (they're not supposed to handle non-Apple products) of removing the shell and repositioning the offending part and seating the SSD. Props to them, too!! He cautioned that he doubted the computer would recognize the SSD but it popped up readily in Disk Utility and I formatted it so all looks good - finally! Thanks again for your responses, Jay. I hope to not be back here very soon.


Glad to hear that you've got your laptop working. What was the issue?


Yorum Ekle

Yanıtını ekle

Bob Enders sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 444