Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1492 Soru Tümünü görüntüle

Option key doesn't work when booting

Hi. My option key stopped working when I boot and I try to use it (for instance, to choose another startup disk or to reset the PRAM). It works normally when I'm using the computer afterwords (after signing in). Also, when my login screen appears, there are a bunch of dots filling in the password field, like if the computer was filling in the password itself (but it doesn't, I have to delete the chain of dots and enter my password). But this dosen't happen when I try (without success) to use the option key on boot.

So:

- If I try to use the option key on boot, nothing will happen but my login screen will have a normal behaviour (empty password filed)

- If I do nothing on boot, I have a self-filling password field on the login screen.

Any help?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

Still didn't work with an external USB keyboard.

tarafından

Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

The dots sound like a stuck key. Check each key on a blank text... there may be another key that is damaged. As a work around You might try a key-remapper OR an external keyboard at boot up. Try holding down the mouse or trackpad at startup, that too may take you to the choose startup disk dialog.

If this answer was helpful please remember to mark it accepted.

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

I actually found a stuck key. It wasn't well in place (after cleaning). Now it's ok but still doesn't work. It's a key that I almost never use. Anyway, the dots are still apearing... But the worst is actually the optionkey, still not working on boot. I also tried to hold down the (external) mouse and the trackpad but nothing happened: no boot menu, the apple appeared immediately.

tarafından

Try using Any USB keyboard (doesn't have to be Apple) holding down the option key.

tarafından

I tried that (with a regular Logitech keyboard which I'm using with my PowerMac) but it still didn't work. I also did a clean install of Mac OS (erasing the HD) and it still doesn't work. It's strange, because if it was a problem with the built-in keyboard the external keyboard should work.

tarafından

Yorum Ekle

The external keyboard will not work on this type of problem. If the key that is repeating can't be stopped by removal, you will need to replace the keyboard. Some of these keyboards can be replaced and some require a top case replacement. Please give us the last three figures of your serial number so we can determine your exact machine.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

Carlos Canhoto sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 11

Son 30 gün: 53

Her zaman: 3,259