Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1468 Soru Tümünü görüntüle

MacBook doesn't work with the battery installed

I recently replaced a logic board in a Macbook Core 2 Duo using the iFixit guide.

The replacement went fine – no issues, but now the Macbook will only work when the battery is NOT installed in the machine. With the battery installed, the machine powers on, but then the screen immediately goes black, no start up chime and the light in front is on (not blinking).

On the replacement logic board I used, the PRAM battery was already connected. I know it might sound silly, but should I have unplugged that from the board and then plugged it back in? The machine is also loosing it’s time setting. I have done the PRAM reset and the SMC reset. I’m at a loss as to what to do now.

Any suggestion would be greatly appreciated.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

Pro Tech Toolkit içeren veya $100tüm siparişlerde ücretsiz kargo!

Mağazamıza Göz Atın

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Strange! The symptoms your computer is showing would tend to indicate you've got a bad RAM slot, but it doesn't make sense that it would show those symptoms only when the battery is in place. But just to rule it out, I would test the RAM slots by trying to power on with only one slot populated, and then the other. A bad slot causes the symptoms you describe when it has RAM in the slot, and the symptoms usually go away when the slot is empty. If that does not cause any kind of difference, I would probably try to re-seat the battery connector to the board, and make sure it's pressed firmly in place, since they need to be plugged in more securely than many people recognize.

I don't think disconnecting the PRAM battery will do much for you. In any case, I would solve the battery issue first, and then see if the time problem is still present. Once your computer recognizes the battery, it should be able to use the battery to keep time, and it's probably losing time now because it does not have either the battery or AC to keep it going.

Bu yanıt yardımcı oldu mu?

Puan 1


I tried both of your suggestions, but it still doesn't work. The battery is charged and I know it is a working battery. The machine won't even power on with just the battery. I think I was just testing it with it being plugged in all the time. I also tried different RAM without success. Is there anything else I can check. I guess it's possible that it's a bad board from the vendor.


Sorry to hear that. The only potential steps you can take are to replace the battery connector, DC-in, and battery, but you know the battery is good, and the DC-in and battery connector apparently worked before the swap (did they?), so it's unlikely they are the issue, and the only real remaining conclusion is that you have a board with a power issue. I'd make the vendor send you a replacement, or better yet get a refund and buy a different board from a vendor that actually tests their equipment instead of putting the burden on you.


Thank you so much for all you help. It is truly appreciated. I did try a different battery connector before originally posting the question, but that also did not work. It was working before the swap. I am suspecting a bad board. In fact, I did another one and it did the same thing. I really don't think it was something I did - could have been, but I don't think so. I really just needed some back up information when I go to my supervisor with the problem. Thanks again.


Yorum Ekle

Yanıtını ekle

lindak122 sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 307