Replaced Logic board, green light when plugged in but won't power up

Ok, so I have a late 2008 15" MacBook Pro and the original logic board is 2.5 ghz, but i've searched and searched and I can't find a decent one for a decent price. So I went on ahead a bought a 2.4 ghz, now that i've installed it, when I plug in the charger the green light comes on, but it will not power up.

Is it because I bought a 2.4ghz instead of a 2.5? Please help me out. Oh the battery was removed as well when I did this.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

As long as you got the same A1260 series board like your system. Do you have the A1226 Santa Rosa system instead? You should be OK. Are you sure the board was good to start with?

Review the iFixIt guide MacBook Pro 15" Core 2 Duo Logic Board Replacement to make sure you didn't forget to reconnect things.

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

well instead of the 2.5 ghz A1260 I got the 2.4 ghz A1260 instead, would that make a difference? this is my first time doing the logic board my self

tarafından

So you did stay in the series so you should be OK. Was this a new board or used? Again, double check your connections. Otherwise you might have gotten a bad board.

tarafından

Why did the original board die? Could there be something else wrong here (not the logic board), like the left I/O board?

tarafından

its a used board, but it said it was tested and it had a warranty of 60 days, where can i get the left I/O board?

tarafından

I see iFixIt parts dept has one Left I/O board.

tarafından

2 daha fazla yorum göster

Yorum Ekle

Yanıtını ekle

Johnny Chen sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 169