Replacement battery is not working, neither is old. Why?

I have been doing tons of research and cannot find an answer that will solve my problem. My battery went out a few months ago when I put in a new hard drive. I did not mess with anything other than the hard drive. My battery has not worked since then.

My Macbook only works when it is plugged in to the adapter, otherwise, it shuts completely off. The battery icon has a 'X' in it. I have checked all setting and the laptop does not even recognize a battery at all. I just bought a replacement and installed it, still having the same issue.

The closest Apple store is a 3 hour drive and I do not have the time to make that trip right now. I have also called and Apple states they would need to see the laptop.

Any help or advice is greatly appreciated.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

Is the X red or black?

tarafından

UPDATE: I called Apple and spoke to someone else. He said that it is probably my logic board and it would need to be replaced. He gave me quotes on how much it would cost for the parts and considering I would have a six hour drive to and from San Antonio, it is not worth it. So, I am going to just deal with the fact that I need to have my MacBook plugged in and just save for a brand new MacBook Pro. Time for an upgrade anyways. I appreciate the help though!!!

tarafından

Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Have you tried an SMC reset? How about NVRAM/PRAm reset? Have you booted into safe (shift) mode to see if there's a extension conflict? … why did you change the HD?

If this answer is acceptable please remember to return and mark it.

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

Oops! I am sorry. Not hard drive...I never replaced that. I replaced the memory because my computer was running slow and Apple suggested to add more memory which worked great. Sadly, in return my battery does not work. Yes, I tried an SMC reset as well as the NVRAM/PRAm reset. Neither worked unfortunately.

tarafından

Yorum Ekle

Yanıtını ekle

jjbksp sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 2

Her zaman: 105