Why aren't my power button and volume buttons responding after repair?

The power button on my iPod Touch wasn't working (stuck in), so took everything apart and replaced the flex cable. I ripped the old cable in two because I was going to throw the old cable away and I didn't care. Then I tried to desolder the old cable (first soldering experience!), but then I ripped this part off.

I soldered the new cable to the board (I ordered the cable from Amazon because I live in Germany and the European iFixit Store doesn't have any iPod parts). Before that I tried to scratch away the old stuff, which has been under the old cable, on the board. I made it like in the repair guide (something with electrical tape) and afterwards it seemed pretty solid.

Then I put everything back together. When I turned it on (with a power cord attached), it booted, but then I realized, that the power button and the volume buttons were not working. They make the click sound, but there is no reaction.

I fear, that I scratched away too much, so the connections are not working anymore. Is this possible?

It would be great, if I just have to desolder the cable and then solder it again (maybe I made a mistake). Is there a soldering expert/pro?

If I have to exchange the cable again, it's ok. If you have a better store for deliveries in Germany, that would be great!

Block Image

Block Image

Block Image

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

Show a picture, and I can help you.

tarafından

Do you mean a picture of the soldering points? If yes: cable soldered to the board or not?

tarafından

yes--ideally, desolder it for a picture, but any picture will help :)

tarafından

I wanted to post the images in the comments, but it wasn't possible, so I edited my post. First picture should be the one with the board only, on the second one you should see the cable soldered to the board in the iPod and on the third it should be desoldered again.

tarafından

Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

It looks like you have the old cable still soldered to the pads. you shouldn't see any copper. you should be able to easily make the pads looks like little silver pillows. Use some flux and massage the pads with your iron---I bet a piece of the old connector will come away from the pad. Ideally, get some of that solder off with some copper braid, it is too much on there.

When you reattach, you want the solder to wick up from the bottom onto the new flex, not overlaid on top.

Also, you a missing a tiny component near the flex. replace that.

jessa

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

Matthias Bahr sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 1

Her zaman: 136