Power/Sleep problems after water spill and fix, capacitors?

I have a macbook pro 13" retina late 2013 model, there was a spill on it and some parts had to be replaced, it works almost like it used to except it has sleep and power problems now. I did run a system diagnostic which didn't give any errors.

It used to work like this:

if you boot it up it works fine, but if you put it to sleep it wouldn't sometimes wake up at all, it worked fine as long it was running without puting it to sleep.

when it doesn't boot up I can see the processor fan running for a while, then it stops for a few seconds and starts to run again, so it's stuck on some loop trying to check something before it wakes up, sometimes it's just running nonstop and the machine would get actually pretty hot.

I figured out that when it was running the loop, and when the fan was running if I pressed the power button for around 7 seconds I could shut the loop completely down and also shut the computer down, if the fan was at the stopped state pressing power didn't work.

After the shutdown If I tried to boot it up with reseting SMC at the same time, sometimes it would boot up just fine.

Also waiting for a while could solve this problem, but at some point I understood that if the mac got stuck on the loop running with a battery it would run as long as the battery had power, so waiting could take a long time, so instead I took the bottom cover off, checked that it really shuts down, so I could see the fan stop, then waited for around 10 minutes, after that I would usually boot. I had to take the bottom off because you couldn't tell if the fan was running by ear.

I managed to crash the mac couple times while playing games, I think this might have something to do with how it handles power while using GPU, but usually I could play for hours without any problems.

I also found out that sometimes the battery information would be lost and it would report the battery missing, but still work just fine, at this state if I put it to sleep it wouldn't wake up.

On windows side running in bootcamp there was hiccups, so if I was playing something, it would stop for a second, the graphics would hang and the sound also hang to some frequency for a half second or so and then it continued just fine.

now, this is how it used to work, so it was painful to boot it up but once it was running it would be ok as long as you don't put it to sleep.

then I upgraded to Yosemite and now I can maybe run Yosemite for 3 minutes and then it just blanks out to the loop, I disabled all power settings from system settings but it does it every time. So after the boot it runs for couple minutes and then gets black, and there's no way coming back from there, I have to shut it manually down, wait for a while and then I can boot it back again.

I just run the diagnostic again and there are no problems to be found, but osx shuts down in around 3minutes after the boot, it also shuts down external monitor if connected.

Now I also found out that there are two capacitor or resistor looking things in a bad shape on my logic board and I don't know if they are properly working, I could try to replace those, but I don't know what they are. From this picture https://d3nevzfk7ii3be.cloudfront.net/ig... just at the left side of GPU there are two vertically aligned white surface mount components, any Idea what they are?

any help appreciated

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

1 Yorum:

I changed two voltage sensing resistors next to gpu on the board, the computer now boots and goes to sleep ok, and can even wake up from sleep, but the temperature is not detected, so what happens is that gpu gets hot and the computer shuts down, I used smcfancontrol to check that there's no temperature detected or if it is it get's lost at some point and the fan speed is at the minium so gpu heats up too much, where can I find out the locations of temperature sensors?


Yorum Ekle