Model A1225 / Early 2009 / 2.66, 2.93, or 3.06 GHz Core 2 Duo processor

167 Soru Tümünü görüntüle

How to identify iMac hard drive model

Hello. My 24'' iMac's hard disk has gone. I started with the OS disc and through the system profile tried to find out the exact brand and model hd to replace it. But I couldn't determine it. Please, help me.

Here are some screenshots:

Block Image

Block Image

Block Image

Thanks in advance for your help.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Your system came with a Seagate 1 TB HD. As you can see the drive within the system profile, are you sure the drive its self is bad? It could be something with the formatting or the OS install that's bad.

If you haven't already made a backup of you're data I would try doing that first. Using your system recovery disk to boot up your system you could try deleting the partition/s and re-install the OS and your apps.

If you want to upgrade your HD here is the IFIXIT guide to take out your current HD: iMac Intel 24" EMC 2267 Hard Drive Replacement.

As to what to use I would recommend going with one of the newer SSHD hybrid drives. You will need to make sure the drive you get is able to run at SATA II (3.0 Gb/s) check the specs sheet of the drive. You can't use the newer SATA III (6.0 Gb/s) drives unless it is able to auto set its SATA speed to SATA II. I would recommend going with a Seagate Desktop SSHD. There are others WD makes one as well but this is the only one I know of that runs at SATA II.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Dan, wasn't there a recall on the 1TB Seagate drives?

tarafından

Yes, for the 27" model. This one should be OK, 24" model. It appears Apple has ended to recall for the 27" model, my link is not working. In the morning I'll ask my guy about it.

tarafından

Thank you for your help. I have already repaired, formatted, checked the disc and restored my data from Time Machine. But the disc past away. I even started in verbose mode and could see the problem was in the disc before format. After that it worked well one day, and since then shows the first picture in my previous post.

Now, with your help I know I have to look for a 3,5'' Sata II (3.0 Gb/s). I'm really bad with hardware :S.

Thank you again!

tarafından

Yorum Ekle

Yanıtını ekle

fquero sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 1

Son 30 Gün: 19

Her zaman: 892