Ana içeriğe geç

Support and repair information for laptops made by Samsung.

346 Soru Tümünü görüntüle

Samsung NP900X4C not accepting charger but runs on battery

2 year old laptop stopped accepting the charger during normal use.

The LED which indicate green for full charged battery and red for charging is no more working. The battery is draining in Windows which mean the computer is not recognizing the charge anymore.

Following is tested:

  • Charger voltage output.
  • Loose connection from charging plug to mortherboard. Connection is perfect
  • Resetting battery with the button on it
  • Memtest+ on the memory
  • Battery calibration in BIOS (recharged with temp solution below)

Temporary solution found:

Unplug mains, battery and BIOS battery. Remove ram memory and put it all together. This makes everything work for a few hours and then it all starts over again. There is no instability, the system is running perfectly fine!

Any suggestions?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2

1 Yorum:

seems to be a power management IC issue. such a waste of a nice laptop

tarafından

Yorum Ekle

3 Cevap

Filtre ölçütü:

disconnect the DC jack pigtail from the motherboard, connect the charger and test the voltage at the pigtail connector. If it is reading full voltage then there is either a problem in the motherboard(most likely) or the charger isn't putting out enough amperage(less likely). If you aren't reading any voltage then the jack is bad.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

I have the same problem. Should the motherboard be replaced?

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Joe... Before answering with the easy answer, read the original question and see how this test has been already performed and charger functioned confirmed and ruled out. I've had this problem and Samsung had to replace the motherboard. It is happening again with the new mobo but when I disconnect the power and reconnect with the unit switched off, it starts charging again. Its a know problem and you need to get this warranty serviced.

Bu yanıt yardımcı oldu mu?

Puan -1

1 Yorum:

I don't think you thoroughly read my answer. The testing I recommended was to test the DC jack to mobo connection to rule the jack and pigtail out as a culprit. This test had not been performed yet. As I stated, if voltage read correctly all the way to the mobo connector then it could be deduced that the motherboard was malfunctioning. I suspect that since OP stated the system is 2 years old it likely is no longer under warranty. You stated this is known issue, is Samsung repairing this specific issue past the standard warranty period?

tarafından

Yorum Ekle

Yanıtını ekle

spagetticharly sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 4

Son 30 gün: 23

Her zaman: 890