Ana içeriğe geç

The W123 chassis covers 240D's, 300D's, 300TD's, 280E's, and several other models of Mercedes coupes, sedans and wagons from model years 1977 to 1985.

107 Soru Tümünü görüntüle

The turn signal is not working but the hazard light is on.

Hi,

The turn signal is not working but

The hazard light is active.

What do I have to replace, the relay?

Regards,

Takuya

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

Hello, it depends on the year of W123 you have.

The very early models with the "big" hazard flasher switch that you push in to turn on the relay is part of the switch. You simply replace the switch as one unit along with the relay.

If you have a later model W123 with the smaller hazard switch that is a toggle style switch instead of a push button switch then the relay is underneath the wood trim that surrounds the shifter. Search around online on how to remove this wood trim - generally it's pretty simple. You remove the ash tray and the bracket for the ash tray and then you can push the wood trim towards the back of the car. It will move backwards at which point you will want to carefully pull up on the back of the trim panel. Be careful not to damage the pin at the back of the trim panel - you need to pull it back far enough to clear the opening that it goes in to! Once the pin is clear the trim should just lift up over the shifter. You will see the relay hiding underneath - it should be the only relay there.

Bu yanıt yardımcı oldu mu?

Puan 5
Yorum Ekle

italic textOn a 1983 240D and/or 1982 300D ... can't remember...I work on both....

The solution to similar problems with directionals and flashers was--

all in replacing that red, console-mounted switch.

I replaced that switch, circa $20-$30; it fixed both flashers and directionals.

I too had previously thought--but was wrong--about a couple things:

1. that a relay / flasher unit might be found elsewhere, but it was IN the switch...... and...

2. when I tried to disconnect / use a short wire connector with allegator-clips / i.e.

"go around" the flashers so that the directionals, at least, would work--

that did NOT work.

It was diabolical--logic did not prevail--it had looked like, surely, as a "quick fix" to at least get my directionals working, tha if I just have the 1 or 2 posts that carry the directionals CONnected, but DISconnect the 4-way flashers posts......

I'd thought that'd be a short-term fix / answer, but it wasn't.

All (5? 6?) posts on a nice, new, clean switch had to be connected.

That console mounted switch is, after all, perfectly situated to spill coffee down over years......

I DID disassemble the old switch / clean / try to rejuvenate the old switch...'didn't work.

Finally--DIALECTRIC GREASE ... 'just happened to have some on hand (from Kent / Mr. MercedesSource.com). ...In case it'll help,...' placed diaelectric grease around new switch to MAYbe decrease chance coffee spills wouldn't be as harmful ???

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

check your grounds and secondary grounds are all tight and clean diesel has a tendency to rattle things loose

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

takuya sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 1

Son 7 gün: 1

Son 30 gün: 7

Her zaman: 2,893