Ana içeriğe geç

Laptop says it's plugged in but not charging! Laptop isn't charging!

Okay, so the problem started a week ago. My Samsung Series 3 np355v5c-a01ub laptop which I bought around 2 years ago is refusing to charge its battery. The battery signal says it's plugged in but not charging. I have tried everything, from taking out the battery, booting it with AC power alone, uninstalling the Microsoft battery thingy from device manager. Furthermore, before my laptop stopped charging, I received strange messages stating I should change my battery. Also, I think the battery life had decreased significantly over the two years.

Would changing the battery fix this problem, or is it a software problem? I read somewhere this could be a mechanical problem i.e. some wire or something actually obstructing the charging mechanism probably caused by overheating, etc.

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0


Having this same problem with a Samsung NP370R5E. It sees the battery, but doesn't charge it.

Tried numerous tips, like draining the battery and removing the ACPI device driver. All did not help.

Replaced it with a no-name brand battery, but that too doesn't solve the charging issue.

Tried to find schematics of the motherboard but haven't found this specific model yet.


Yorum Ekle

1 Cevap

Filtre ölçütü:

If it’s not charging you either need a new battery or a new cord. The battery could be not charging because it’s too old or broken. The cord could be broken internally or not all the way back in the input

Bu yanıt yardımcı oldu mu?

Puan 0


Thanks for your suggestions Norwolf.

The cord is fine, because the laptop works when it's plugged in. When I remove the cord, it shuts down because the battery has been drained and doesn't charge.

When I replaced the battery, same thing: laptop worked on the remaining charge, but when that too was drained, I needed the cord to keep the laptop working.

Also, Windows 10 is happily telling me I have a battery, a cord plugged in, but it is not charging. Unfortunately it doesn't tell me why it is not charging.

Hence, I suspect the charging circuit on the motherboard.

Continuing my search for schematics so I can diagnose that part.


Yorum Ekle

Yanıtını ekle

Ayy Lmao sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

Her zaman: 262