Ana içeriğe geç

The Dell XPS 15-L502X laptop was manufactured by Dell Inc. It was released in 2011 with a 2nd Gen Intel® Core™ processor.

17 Soru Tümünü görüntüle

Why is my USB port not working?

why is my USB port not working?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0


I am online searching for a fix to NO USB ports working on my computer. EVERY single response I see says to "type this.." or "click that..." How can I type or click if the USBs are not working? I have no keyboard or mouse??


Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm


Go to Device Manager and see if there are is a red cross or a yellow exclamation mark against the Universal Serial Bus Controllers entry.

Depending on your OS, go to Control Panel > Device Manager scroll down to USB controllers, highlight the entry with the cross or mark.

If it is a red cross, right click on the entry and click enable. See if your USB now works.

If it is a yellow exclamation mark, right click on the entry and click on Properties in the window that opens. In the window that opens in the middle box in the General Tab is a message that indicates that there is a problem with the device. To try to correct the problem, click Cancel , then right click on the highlighted entry again. This time select Uninstall. Follow the prompts then exit device manager and restart your PC. Hopefully it will detect that you have 'new' hardware and will re-install the drivers for it, or find new drivers for it. When the PC has completely started go back to device manager and see if there are any yellow exclamation marks against the USB entry. If not test your USB port.

If there are no red crosses or yellow exclamation marks against the USB Controllers entry in Device Manager and it still doesn't work, right click the USB root hub entry, click properties, click Power Management then uncheck 'Allow the computer to turn off this device to save power Do this for all root hub entries if more than one.

Restart your PC and see if the USB works.

If it still doesn't work and you have no indication in Device Manager that anything is wrong, you may have a hardware problem with the actual USB port. With a magnifying glass examine the USB port and check that there are no broken or bent pins. If it seems OK then you may have to open the PC to inspect the USB ports connection to the motherboard.

Bu yanıt yardımcı oldu mu?

Puan 5


2018 and this worked with me for windows 10. i unchecked all the "allow this device to turn off" options and it worked! my front port USBs work again!


Yorum Ekle


If the problem not driver's or windows

So its hardware problem almost there is resistor near usb .

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

bamigboye Lummy sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 Gün: 23

Son 30 Gün: 123

Her zaman: 8,302