Ana içeriğe geç

Model A1200 with 2.16 or 2.33 GHz Core 2 Duo processor

137 Soru Tümünü görüntüle

How does one determine what is causing white screen?

As Shipped Unit Description:

  • Serial Number: W87130ZKVGN
  • Type: iMac "Core 2 Duo" 2.16 24-Inch (T7400)
  • Intro.: September 6, 2006
  • Disc.: August 7, 2007
  • Order: MA456LL
  • Model: A1200 (EMC 2111)
  • Family: Late 2006 - 24"
  • ID: iMac6,1
  • RAM: 1 GB
  • VRAM: 128 MB
  • Storage: 250 GB (7200 RPM)
  • Optical: 8X DL "SuperDrive"


System boots to the point that it shows a white screen with a cursor that can still be moved (ie. not frozen). Need to determine what needs to be repaired to put the unit back in service? Can't be sure whether it is a board failure or not.

What I've tried

Tried booting off CD and can get access to see choice of boot drives, can see verbose startup, and can see drive contents. Booting of internal drive results in a white screen with a movable cursor no matter what key combinations or cache clearing "tricks" are tried. Disassembled unit and connections appear OK. Have not been able to figure out how to remove "back" to check other side of logic board, but caps on power supply appear fine.

Additional details of things tried

  • Hard drive itself seems to be functional, based on checks after booting from CD.
  • Makes all the right noises on startup before the apple and spinning gear.
  • Holding down option key on startup works ok. Shows the partitions on the hard disk.
  • Holding down shift key on startup doesn't work. Goes into white screen and stays there (but shows movable cursor).
  • Holding down D key on startup doesn't work. Goes into white screen and stays there (but shows movable cursor).
  • Holding down command V (verbose mode) doesn't seem to work.
  • Resetting SMC, PRAM, safe mode doesn't work.
  • Prior to failure didn't give any indication that video card was failing. I.e. no lines, no break up or distortion of images.
Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3


Pulled the hard-drive cable and verified that I got a file folder with a flashing "?". Then tried booting off an original Leopard install disk. The "boot" progressed to a blue screen with an active pointer cursor. That is as far as it went. Given that a similar machine without a hard drive went all the way to the install menu, it appears that the hard drive is not the problem.

Can someone provide an idea what I can try next? A graphics card is out of the question. The machine is not worth the investment, but maybe the problem is something easier to fix. Not sure how to tell for sure.



Found the original disks for the system and was able to run the extended version of the diagnostics several times. It says "No trouble found". Not sure what this tests, if anything, beyond the explicitly stated memory and logic board. Does not seem to "test" graphics, but it does use them in the diagnostics program.

I should note that the diagnostic program shows 2GB installed, not 1GB as originally posted. Have verified this is correct by inspection of the memory installed. The video card is an NVIDIA GeForce 7300 GT w/128MB VRAM.

Next, I tried booting off the original install disk. I got as far as the system displaying a message to shutdown and restart the computer. Presume this is a "Kernel Panic", but am not sure at the moment what I can try next.


Yorum Ekle

1 Cevap

Filtre ölçütü:
En Yararlı Yanıt

Excellently stated question! Your problem is most likely your hard drive. If it boots from the DVD, reformat the drive (use the write zeros option as it will them map out any bad blocks) and reinstall the system. That failing, replace the hard drive.

Bu yanıt yardımcı oldu mu?

Puan 3


Thanks, Mayer. I'll reassemble the unit, boot from the DVD and then try reformatting (with write zeros option) and finally re-install system. I'll post a response to tell you how that went.


Used the option key to get to select the boot volume, Selected the DVD (OSX 10.5.1). Went through the white screen. DVD drive was active periodically. Finally seemed to stop at a blue screen. Cursor was still able to be controlled, but there was a copy of it frozen in place as well.

If I move the cursor to the centre, I get an I-beam. It is definitely because of some field that is not visible. Every so often, I can hear the DVD seeking and then it goes silent. Sounds like the graphics card might be unable to function in all modes, but the system may have booted.

So; tried and was able to boot to single-user mode. Did a "/ root# /sbin/mount -uw /". System reported "Removed 0 orphaned / unlinked files and 11 directories." Was able to move around the drive and list directories. When I issued the command "EXIT" it went as far as "DSMOS arrives..." then I see a fail message that is too quick to catch and it goes to the white screen. Have you any suggestions on what to try next?


Tried booting off a USB and managed to get a spinning beach-ball. I'm starting to wonder about the graphic card being bad. If it were, I would expect such graphics not to be visible. Am going to try mountain lion on a USB and see what happens.


Mountain Lion 10,8 will not work with your processor:

Pre-Installed MacOS: X 10.4.7 (8K1106) Maximum MacOS: X 10.7.5*


Tried my old Leopard install disk using an external usb dvd drive. The system got as far as a solid blue screen, a copy of the cursor was showing in on the screen and the actual cursor was also still active. At this point, it stopped accessing the CD and went no further. I've tried Lion on a usb stick with no success. Not sure what else I can do. Suggestions???


3 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Gary Gauthier sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 3

Her zaman: 603