Ana içeriğe geç

Repair guides for cameras of the now-discontinued Minolta line.

85 Soru Tümünü görüntüle

Minolta X-570: Why can't I advance my film, the lever won't move

One day I shot a picture using my Minolta X-570. The shutter worked normally but when I tried to advance to the next shot, it was if the gears in the camera were locked.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Apparently this is a common problem with the X-570 and the X-370.

When this happens, it means that the shutter mechanism has not fully completed its cycle. This may be due simply to "lack of exercise" - the mechanism may have become a bit sluggish - or a problem with the electronics. Apparently, the electronic circuit that controls the shutter has a part (a capacitor) that tends to fail due to old age. People tell me it's a relatively easy repair, and repair shops familiar with Minolta bodies will fix this problem at moderate cost.

To unblock the mechanism, gently whacking the bottom of the camera against the palm of your hand might help. But it would be a good idea to start looking around for a competent repair shop. Ask veteran photographers (those who grew up using film cameras) for leads.

Bu yanıt yardımcı oldu mu?

Puan 4
Yorum Ekle

Yanıtını ekle

tytypunkin sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 18

Son 30 gün: 55

Her zaman: 4,386