Ana içeriğe geç

iPod Nano charges but won't connect to USB on any computer

My iPod nano suddenly stopped connecting to any computer.

When I plug it in it will charge, but not connect, it doesn't show up in iTunes, explorer, disk manager or device manager. The iPod is otherwise fully functional.

Things I've tried:

Hard Reset (both when connected and not)

Disk Mode

Original Apple cable, and aftermarket cables (charges on all, won't connect)

Uninstalling iTunes

Restarting computer with iPod attached

Uninstalling all USB drivers and restarting

Plugged into Windows 7/10 and OSX, no change.

I even tried connecting it to an android phone with an adapter .

Reset iPod settings

I am pulling (what little is left) of my hair out with this! I have come to the end of the internet and I've run out of options, the only thing left to assume is that it's a hardware issue but it was literally working, then sat on a desk for a bit, then stopped working, nothing happened in between and it never had any issues before.

Any insight is appreciated, even solidarity if you are experiencing the same thing. It's just so frustrating, at least if it showed some sign of connectivity I would have a glimmer of hope, but I have nothing to go on if I can't even try to access the device.



Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

I fixed this problem by first disconnecting the device from the USB cable and restarting the device. To restart (ipod nano 2nd gen), hold the middle button and the menu button until the screen goes dark (i let go when it darkened and it still worked) After a short wait the apple logo should appear. Wait until your device powers on and shows the menu. Now your device should connect to your Mac/PC. Note this will NOT erase your data, just restarts the device.

Bu yanıt yardımcı oldu mu?

Puan 2

3 Yorum:

Thank you so much i will truly be eternally grateful


This totally worked for me! Thank you!


Boomshanka! Thanks VERY much - worked a dream. And... why didn't I think of this earlier?


Yorum Ekle

It is a hardware issue but the question is what hardware, try any of the cables on another device and see if the computer sees it, if it does then it is the iPod (most likely some of the pins on the port are broken) and... Ya.... Nothing you can really do...

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Sadly I agree that it's likely a hardware issue. But I don't understand how, it worked just fine, then sat on a desk for a bit, then didn't work anymore. I suppose I could try to replace the logic board if I can find a replacement. I'm looking for my old 80GB iPod video to connect and see if my computer will recognize that. At least I can confirm then that it's a hardware problem and not that apple has put a curse on my house or something, haha.


Yorum Ekle

Yanıtını ekle

Joseph sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 24

Son 30 gün: 96

Her zaman: 3,876