No power to mac

Hello, I received a a1342 from someone in my family recently, I'm quite experienced with laptops but this is my first go at a mac. So at first they told me it wouldn't take a charge, looking online people said it was likely the battery or onboard dc.. anyways like I said they told me it wouldn't take a charge at all, so dumb me figured to tell them to get a new battery, battery comes in and it boots up! Works great until it dies, I went to go charge it but it won't charge! So I got a new onboard dc, and now it still won't charge :(

I've tried resetting sMc, doing this I've been able to get the charger light to go amber a couple times, can't reset pram because theres no way to boot it.. I've tried holding power taking the battery out putting the charger in, then the battery.

I've tried removing the keyboard flex cable and booting

I've tried powering without the battery in, doesn't turn on :(

This confuses me because it started when it did have a charge... there were no spills or anything . Maybe it's the charger or something else that delivers power to the battery but I'm not sure.. appreciate all replies

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle