Ana içeriğe geç

Touchpad doesn't work after front panel replacement


My ASUS R510JK (also known as X550 in most parts of the World) had really messy front panel so I have decided to replace it. I have ordered the part and installed the touchpad from the previous panel to the new one. After I have mounted the new front panel and powered up the laptop the touchpad didn't work. I have checked the ribbon cable and it seemed like it is quite messy to, so I have trimmed it - no luck, still not working. I have ordered another ribbon cable, but it was to short to connect it and fully close the laptop so I have checked the touchpad without fully closing the front panel - still wasn't working. How can one be sure that the touchpad has broken? Everything is connected and fits well, under device settings I can se the yellow (!) next to the TOUCHPAD. I have tried to update the drivers / ATKPACKAGE and so on - still no luck.

My question is - how could I broke the thouchpad just by mounting it to different front panel? Are those parts that delicate? Will replacing the touchpad with new work out based on the things I have written?

I will be very grateful for any feedback.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

iPhone Pil Tamir Setleri

Only $29.99

Buy Now

iPhone Pil Tamir Setleri

Only $29.99

Buy Now

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

You said that you trimmed the flat cable. Even though it may look the same, the part that you cut off has a short section at the end that is usually conductive, whereas the rest of the cable is insulated. So once you cut off a bit the end of the cable is now insulated and will not make contact with the connector. Depending on the design of the cable you may be able to recover from this. What you need to do is remove that insulating layer from the last 4mm or so of the cable. If you look at the connector, you will see metal contacts one side, usually the printed circuit board side. That, is the side of the cable that you're going to want to make conductive by removing the insulation which is usually a layer of very very thin plastic or lacquer. Try this: get some 1000 or 1500 grit wet-or-dry sandpaper from an auto parts store. GENTLY remove the clear insulating layer at the very end of the cable without also removing the conductive traces. Depending on the type of cable this may or may not be possible to do. Then plug the cable back in and see if it works. Also depending on the design of the cable you may need to use more or less fine sandpaper. Good luck!

Bu yanıt yardımcı oldu mu?

Puan 1



So for example if this is my ribbon cable, I should gently scrub the white part and reveal more silver parts that will be long enough to connect to the slot properly?

This is great tip. So you say that the cable might be faulty and if i acquire new one this might resolve the problem? If not - if you were me, would you consider replacing the touchpad or tried to look for the problem elsewhere (motherboard for example)?


If there's a connector on each end and you can replace the cable, it's probably best to do so. Even if you are able to make the end conductive again it won't be plated and may oxidize over time.


Ok, I think I will acquire the proper cable. One question, because you seem to know a lot, when do touchpad starts working? What makes it work? Just connecting the ribbon cable or it has to be mounted to panel in order to conduct and work? Because as I said in the first post, I have tried starting the laptop without front panel just with touchpad connected with shorter ribbon from different laptop (pin number was the same, just shorter cable) but it wasn't working.


Yorum Ekle

Yanıtını ekle

jarzus sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 5

Her zaman: 122