Ana içeriğe geç

Fix Your Stuff

Right to Repair

Parts & Tools

Model CUH-ZCT1. Released in November 2013 by Sony Computer Entertainment, this six-axis, 3.7 V lithium ion battery controller is uncomplicated to repair.

234 Soru Tümünü görüntüle

L2 and R2 /buttons 7 and 8 stuck after cleaning

Hi guys, I had a rather trashy looking but fully functional dualshock 4 - so I ordered a new shell, buttons, ribbon cable, etc from ebay to rebuild it. Basically everything is brand new except for the battery, motherboard, and usb board. Upon reassembly the controller works fine in the PS4 menus, but not at all in game, which lead me to suspect a stuck button. I plugged the controller into a windows 7 PC to test it, and in the controller settings *(where you test the joysticks and button assignments) it is saying buttons 7 and 8 are constantly pressed (L2 and R2 triggers) but the triggers respond OK on the analog testing axis. So while it appears the buttons are stuck, they aren't. any ideas? everything in the controller is new - new conductive film, new buttons, new rubber membranes, new shell, etc so I know it isn't a case of a dirty pad or contact. the L2/R2 springs are new as well, and everything feels like it is installed correctly.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

I finally fixed my problem after a few weeks... Turns out I had ordered a new membrane from eBay and it turned out I had bought a bad one. I bought a new membrane and it worked fine. There are also a few different versions of the plastic membrane floating around. I bought one that was a different color (some are green some are blue) try a different membrane and it will probably fix the problem.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

My controller has R2 pressed on all times, I even removed the button and tested it on pc and it showed that it's still being pressed even when there's no rubber on the button. What's wrong with it please help me out.

Bu yanıt yardımcı oldu mu?

Puan 0

Yorumlar:

Just in case anyone else Picks this one up...

I had this same problem and solved it by replacing the membrane/conductive film (£4 on ebay)

I couldn't see any damage on the old one but replacing it solved the problem.

tarafından

Yorum Ekle

Urgh, I hate that. It’s likely pinched by the shell. Just take it apart and put it back togeather again.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Chris sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 7

Son 7 gün: 85

Son 30 gün: 232

Her zaman: 2,876