Skip to main content

Fan not turning on at system start - kboard + mouse errors

Hey guys I recently opened this model to replace the hard drive and DVD drive. When taking it apart the previous mac engineer had placed the fan connector in an inaccessible location meaning when I tried to get it out I pulled a couple of the wires out from the plastic sheath (the cable that connects the fan to the motherboard).

I had the fan tested by an electronics specialist and it still works so I pushed the ends back in and they seemed okay. Just reassembled the PC and the fan didn't start when the system turned. I remember hearing that macbooks are mostly passively cooled so the fan won't always start, any confirmation on this?

Also the keyboard and mouse weren't working in the OS recovery environment. I plugged a usb mouse in which worked fine so it hadn't crashed. I'm right in thinking their connectors only go in one way yes?

Update - 7/12/10

First off I discovered this model is a 1.33GHz not 867mhz but from I used the 867 guide and it did not differ greatly. Got the keyboard and touchpad working in the end then spent a while trying to monitor temperatures (the usual tool Hardware Monitor doesn't support OS X 10.3) to see if the fan was working correctly.

Then I discovered that the inbuilt hardware diagnostic tool on the OS X disc can tell you if there are any hardware errors. This reported back the error

***error*code***error*code***

2fan/4/1: Rear main enclosure

***error*code***error*code***

From which I deduce the fan is not working, all other features were working fine though (bluetooth, sound, display, wireless, lan, etc) so I am looking to acquire a new fan as can't find a replacement end for cheaper.

I want to test the new hard drive I put in (as the packaging it was delivered in was not sufficient in my estimation) I've reinstalled the OS on the new drive and it seems stable but I'm a windows man so don't know which tools would work, would the Apple tools do a full surface scan?

Finally does anyone know the full model number of the screen so I can look into the price of a new one.

Answer this question I have this problem too

Is this a good question?

Puan 0
Add a comment

Android Tamir Setleri

Yeni bir ekran veya pil, bir tamir kiti kadar yakınında.

Hemen Alışveriş Yapın

Android Tamir Setleri

Yeni bir ekran veya pil, bir tamir kiti kadar yakınında.

Hemen Alışveriş Yapın

1 Cevap

Most Helpful Answer

Sounds like you didn't get a complete connection by just pushing the ends back in. Use a multimeter and test fro continuity. It also sounds like you didn't get the keyboard cable pulled correctly into the logic board. Try again and use some electrical tape to hold it in place.

Was this answer helpful?

Puan 2

Yorumlar:

good answer +

by

I used a Samsung HM160C hard drive btw, picked up and formatted no problem

UK best price is £35 at ebuyer

by

Add a comment

Add your answer

Joel Spencer will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 2,061