Ana içeriğe geç

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1484 Soru Tümünü görüntüle

problems stays after changing dc-in

Have a macbook 1.85 GHZ intel Core 2 Duo, Battery won´t charge, no green/ red light. The macbook does take power from the outlet! I changed the DC-in board but the problem continues! Might it be the mother board?

Update

here is what coco says

Battery charge

Current charge: 961 mAh

Max charge: 3865 mAh

24% (yellow)

Battery capacity

current capacity: 3865 mAh

design capacity: 5020 mAh

76% (green)

Mac model: MacBook 2.1

Age of your mac: 48 month

Battery loadcycles: 732

Battery temperature 29.7C

Battery power usage: 0.0. Watt

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

4 Cevap

Filtre ölçütü:
En Yararlı Yanıt

It could be you have a bad battery connector or a bad battery. You can download and use Coconut Battery to check the age, current capacity, and cycles of your battery. If the battery looks good, then I would replace the battery connector.

Update

Battery connectors can go bad over time. No real cause other than usage.

Based on the stats your battery looks fine. Have you tried using a different AC Adapter? I have run into a similar problem with my own MacBook where the MacBook will run off the AC Adapter, but will not charge the battery. I changed the AC Adapter and it fixed the problem. Also, I could fix the problem by bending the cord near the MagSafe plug certain ways. Not sure if that meant there was a short in the wires. I just got tired of having to mess with the cord to charge the battery and got a replacement AC Adapter.

MacBook Battery Connector/Sleep Sensor (non-Energy Star) Resmi

Ürün

MacBook Battery Connector/Sleep Sensor (non-Energy Star)

$7,99

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

+ excellent answer

tarafından

Yorum Ekle

Test the AC adapter with a multimeter. Look at the tip and use a toothpick to move the pins in and out, (do this while unplugged).

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Matt, thanks for you reply, but what possibly could be wrong with the battery connector? And why the light of the mac adaptor does not show green or red?

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

mayer, I do have a multimeter but do not understand what should be doing?

The small magnetic plug has five pins and yes I noticed that they move inside when you push...

But what should I be doing with the meter? What should each pin show?

Matt, I used another ac which did not work either so I assumed it was the dc-in board.... but after changing it the problem stayed (used my adaptor on another mac were it worked correctly)

Another strange fact is that my ethernet port does not work either (software says that there is not port present)

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

willem sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 0

Her zaman: 960