Ana içeriğe geç

2.5 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.1 GHz) with 3 MB shared L3 cache.

266 Soru Tümünü görüntüle

Replaced battery and macOS still reports No Battery Available(black X)

I have a late 2012 13" Retina MacBook Pro with a "No Battery Available" problem. I just replaced the battery and the issue still persists. I have reset the PRAM, and the SMC several times. I have tried draining capacitors (held power button) while the battery was disconnected as well.

I find it unlikely that the new battery is the issue, what is the next step in diagnosing? I do computer repairs, however I don't have enough information to diagnose problems with the SMC circuit, etc. There is no water damage and nothing appears damaged on visual inspection.

Does anyone have specific information about the SMC circuit, fuses, etc. that I should look at? Thanks!


I added this image after reading Reece's helpful answer. (See my comment below.)

Block Image

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
4 Yorum

I'd say the problem is the corrosion on the R5280 resistor as seen in the photo I added above. The one just to the right doesn't look so great either. I'm accepting the answer from Reece, thanks!

Now besides the obvious cleaning, this resistor is a smaller one. Why would this particular resistor be corroded? There was no apparent water damage. This appears to be a pulldown resistor. Do higher current circuits generally corrode first? I've only soldered SMDs twice this length (4x size). I will look for additional hints on how to solder components this small, if it needs replacing.


This resistor fell right off when I tried to test the resistance. How do I tell what resistor to replace this with? The schematic shows 2.0K 5% 1/20W MF 201. Does this mean I can get any 2K Ohm, 0.05 watt, 201 package SMD resistor?


That's great, replace both resistors and that will definitely sort your issue.

In terms of how this is damaged, the resistor is corroded (caused by liquid damage), which explains why it fell of when you tried to measure it. You may need to lightly scrape the solder pads when soldering a new one, since these are likely corroded too.

You are correct, this is a pullup resistor, used to allow the battery to communicate with the SMC, to let it know the percentage, etc. Best to use a hot air station to remove and solder a new resistor, and a solder iron to apply new solder to the pads. Higher voltage components are usually the first to corrode, but in this case, it looks like a random spot of liquid damage (usually this happens when a few drops of liquid goes through the vent and hits the fan, spraying it on the board).

Yes, that is the right resistor you need (haven't got board view/schematic in front of me, but as long as you select the right resistor, that is correct).


Remember to replace the other bad one too, this is likely just hanging on as well.

Good luck :)


Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Make sure the square contact part (under the battery) is the correct orientation. Make sure all the correct screws are in to push the battery into this, and hold the plastic cover over this (without these, it will not recognise battery).

Get a schematic and board view, and measure R5280 and R5281. Check the voltage line from the battery to the logic board, chances are something is burnt or blown. Follow the voltage from the battery until it is not present, or see if something is shorting this to ground.

Bu yanıt yardımcı oldu mu?

Puan 3

2 Yorum:

Thanks for the answer Reece! What's a good source for the schematic or board views?

I'll follow the voltage line from the battery, I didn't start to attempt this because there seem to be a lot of paths from the battery, the square interposer has lots of contacts.

I was careful to replace the screws in the exact same arrangement, it helped that I've replaced the SSD in these MacBook Pros several times and had to disconnect the batter each time by removing those screws.


Just Google "*your board number board view" and you will come across some websites. On A1425, the board number should be along the top of the board under some black tape. Use the battery page of the schematic to find the voltage name for the battery, then measure the points using board view


Yorum Ekle

Was this fixed ? I think I might have the same problem. Think I might have blown something by not aligning the interposer correctly

Bu yanıt yardımcı oldu mu?

Puan 0

2 Yorum:

Hi Kris,

Yes, replacing those resistors did fix the problem perfectly. Sorry I didn’t notice your comment earlier. I hope you were able to resolve your issue then!


Did you source and purchase the mentioned resistors or did you replace them from a donor board? Thanks


Yorum Ekle

Yanıtını ekle

gatortpk sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 11

Her zaman: 724