Ana içeriğe geç

Model A1225 / Mid 2007 and Early 2008 / 2.4, 2.8, or 3.06 GHz Core 2 Duo processor

427 Soru Tümünü görüntüle

Powers up, no chime, three LEDs, then shuts off.

I found a few posts with similar issues here but nothing exactly matching my situation. Of course, this is my personal machine. :-)

My iMac is generally running 24/7/365. Two days ago when I got home I discovered my house had suffered a power cut; the microwave clock had reset itself and my iMac was off. I was unable to turn it back on. I unplugged, waited, then replugged and pushed the button. I could hear the fans kick on and the optical drive do its little POST, then it shut off again. Once that happened pushing the power button did nothing; I had to unplug/wait/replug to try it again.

I have it on the bench now. LED 1 lights up when it's plugged in. LEDs 2 and 3 light up when I push the power button, but ~3 seconds later LEDs 2 and 3 turn off followed immediately by LED 1. LED 4 never lights up.

Unplugging the screen's power and signal doesn't change anything.

Memory tests good.

Resetting the SMC does nothing. Resetting the PRAM is impossible.

According to this guide, no LED 4 means the computer and display panel aren't communicating. BUT! There is one capacitor on my power supply which appears to be ever-oh-so-slightly leaking (in the middle):

Block Image

Prior to the power cut the iMac had zero problems. I'm thinking my plan of attack would be to replace the capacitor, see if that brings the screen up, and if it doesn't then just replace the screen. Good idea? Or should I just bite the bullet and replace the screen right away? Or is there something else I should check first?

EDIT: I can't find a pinout or schematic for this power supply, but I measured the voltage anyway using this video as a starting point, even though it's for a different iMac model. Facing the connector on the board with the retaining clip on top, the upper-left conductor is Pin 1 and the lower-right is Pin 12.

Pin 1 = 0

Pin 2 = 0

Pin 3 = 0.09

Pin 4 = 0.09

Pin 5 = 0.09

Pin 6 = 0

Pin 7 = GROUND

Pin 8 = 0

Pin 9 = 4.21

Pin 10 = 0

Pin 11 = 12.76

Pin 12 = 0

According to the video I should be getting 12V out of Pin 11 but since it's a different iMac model I'm not 100% sure.

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Your power supply is failing just as you suspected. You can attempt a repair of that cap. Caps can be gotten at www. mouser.com if you have the time and skills. otherwise just order in a new one.

There is not a guide for the 24" but there is one for the 20" that should get you there: iMac Intel 20" EMC 2133 and 2210 Power Supply Replacement

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

It took about 10 minutes to get the old capacitor out (what is it about OEM solder that makes it such a PITA to remove?) but once I swapped that bad one with a new one and hooked it all back up, it started up on the first try. Thanks for the help/confirmation.

tarafından

@secondlife Well done, congratulations! Now just watch out for any cascading failures.

tarafından

I’m having the exact same issue. My first thought was also the power supply. So I replaced the power supply with a working one but this did not fix the issue. Could there be something else that would cause this continued loop?

tarafından

Dan you you start a new question on this as your problem sounds different.

tarafından

Yorum Ekle

Yanıtını ekle

Steve Godun sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 1

Son 30 gün: 3

Her zaman: 398