Blank screen and not booting

I was walking my dog when i dropped my phone. Upon later inspection I found the back glass to be shattered and it would not do anything. I used a heat gun and a suction cup to remove the shattered glass, and then vacuumed the inside of the phone, with no results. I then unplugged and reconnected all of the cables that were accessible, and instantly it started up. Feeling quite relieved I left it to charge up, and put my case on to protect the fragile electronics inside. Later in the day, while I was using it, The screen blacked out, without shutting down, and i was returned to my first problem of it not booting. I plugged it in and saw that the LED lit up red, but then started flashing. I would get a blank screen then it would turn off. I instantly assumed a broken bootloader, and did a software repair with Xperia Companion. The repair was successful but yielded no results. I was running entirely stock firmware with no root and my bootloader was unlocked. I then entered fastboot mode, which was fortunately working, and rooted and unlocked the bootloader using FlashTool. I then installed TeamWinRecoveryProject and rebooted into recovery via ADB. I was met with the same flashing grey screen and decided to flash Resurrection Remix through flash mode, which left the screen grey instead of turning off again. I then tried ClockWorkMod Recovery and a stock ftf of nougat 7.1.1. I am confused, maybe fried motherboard? But fast boot is fully functional and so is the vibrator motor and LED.

Any help would be greatly appreciated.

UPDATE: This morning I did an Xperia Companion software repair for the second time, and when I tried to boot it up it showed a low battery icon. I plugged it in to charge but could not commence any further troubleshooting for I needed to go to work. When I returned home I saw it was on 100%, and upon booting it up I accidentally unplugged the battery. When I plugged it back in again, I found I was back to the blank screen flashing LED cycle again. The next day I took it to a third party mobile phone repair place, who are inspecting it now. I have ruled out an LCD fault, for the battery icon showed up. Maybe a faulty cable? But I took apart the bottom speaker and display cable arrangement, and all seemed fine. I am thinking it could be corrupted bootloader software, but I'm not too sure. I git the device back from the repair company and they said it had corrupted system files, which they were not legally permitted to fix. I downloaded a stock firmware ftf file from XperiaSite and flashed it with Flashtool. I was getting a steady orange charging light but upon booting it up i was met with a blank screen which stayed there until I did a simulated battery pull. Again, I would be eternally grateful to anyone who could help, because I don't really want to pay $900 for an XZ1.

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle