Ana içeriğe geç

The April 2014 update of Apple's 13" MacBook Air features refreshed dual-core i5 and i7 processors, plus slightly increased battery performance.

317 Soru Tümünü görüntüle

Changed out the EFI chip on this MacBook Air and now it won't power on

I recently bought an Apple MacBook Air, and stupidly didn't check to see if there was a firmware password on it or not. The old owner doesn't know the password. So, I purchased a pre-loaded EFI chip for this specific model (a1466 EMC2632) and followed a tutorial on youtube on how to replace the EFI chip with a heat gun and flux. I did so, and I reassembled the logic board and doubled checked to make sure every cable was plugged in properly. I plugged in my MagSafe charger and it doesn't show a green light. I pressed the power button and nothing came on, no sound, no battery symbol.

I thought maybe the BIOS chip was bad, but would that prevent the entire computer from powering on? The battery is still good, the cables are all plugged in securely. I don't know what exactly could be causing this, as I didn't do anything other than heat up the EFI chip and replace it with a different one (which is from the same model MacBook Air). I know the charger works properly because it charges my MacBook Pro just fine.

any suggestions? Is there something that could go wrong in re-mounting the logic board?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 3
6 Yorum

Did you ever get anywhere with this? I just changed a chip on mine and my charger does have a orange charge light, but doesnt power on. Not sure if my battery is dead or I may have to try goin back to my old chip. If you were like me and got the chip on eBay from china I guess being defective is an option...I used a reflow oven so pretty sure nothings out of place.....


If the chip is not soldered properly, the Mac will not power on at all.


Did you ever figure out what happened? I tried doing the same process with my macbook pro but unfortunately the laptop wont boot up. Right now I have my laptop charging. Whenever the white light blinks while being charged I hear a noise from the hard drive and the fan turns and that process repeats itself. Any suggestions?


Hey there, Did you figure out what the issue was? I am looking to do the same thing but not sure about how to best remove /replace the EFI chip.

Who did you buy the EFI chip from on Ebay?

About to buy this one,.


Is there a site I can get the bin file to program the chip?

Recently replaced the EFI chip for iMac a1311 now screen will not come


1 tane daha yorum göster

Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

This could come from different things:

  1. your new bios chip is not proprely programed or erased or faulty
  2. you inversed the chip position when mounting
  3. you knocked down some little resistors surrounding the bios chip

Recheck around the bios chip for missing components and then recheck the rest of the motherboard

Bu yanıt yardımcı oldu mu?

Puan 2

4 Yorum:

The chip is mounted properly, not inverted. I took a picture of it before removing the previous chip. I also cleaned up the area around the chip because there was some left over flux. None of the components are missing. would a faulty bios chip cause the computer to not power on? The charger won't event indicate a green light when I plug it in. would that be normal for a faulty chip? I will probably try putting the old chip in to see if it powers on, so that might narrow down the issue for me. If it powers on with the old chip in place, then it means the new chip is bad.


the bios chip has no effect on the green or amber light of the charger. that is a charging problem.

Just to be sure recheck the flat cable from the magsafe daugtherboard to the logic board.


Heat guns are not meant for replacing logic boards components. Air flow is too strong and heat regulation is quite rough. Wouldn't be surprised something got blown away or burnt in the process.


If the bios is not firmly flat on the board or if a pin is not soldered properly it will prevent the macbook from turning on. You need to remove the unleaded solder from the pads, especially the ground pad. The unleaded solder requires a lot of heat to melt, so remove it and replace it with leaded solder before installing the new chip. I've seen many machines fail to start after replacing the BIOS and in most cases its due to poor soldering.


Yorum Ekle

You should have just flashed it not replaced it.

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Can a BIOS chip from a Macbook air a1466 EMC 2925 2015 work on macbook air a1466 EMC 2632 2013.


Yorum Ekle

I know this is an old thread but I was curious to know how this worked out. Although there is a chosen solution, no one ever indicated what the problem actually turned out to be or what actions fixed it (a problem all too common on help forums).

The things to look out for (and it sounds like you probably did, Tiffany) are making sure that the chip is oriented properly, that the solder pads are cleaned and fluxed before soldering, that each pin is soldered, that there is no solder between pins and that the chip is not overheated.

There are many high-quality hot air stations that are quite affordable; just make sure that the air-flow can be set low, so as to avoid moving adjacent SMDs (surface-mounted devices) while working on the EFI chip. The ratings and reviews by other users will guide you. I use Kapton tape (a high-temp masking tape specifically for operations like this) and foil to mask off the surrounding area, if there are other SMDs too close to the work area. On a laptop, the components are often very close together; watch closely to make sure no adjacent components are moved; if they are, gently nudge them back onto place before removing the heat.

About the power light; that actually sounds like something other than the EFI chip; the EFI chip contains the basic instructions that tell the system how to start up, test its basic hardware, detect the boot drive and start reading the OS into memory. The green LED is actually wired to the SMC chip, which illuminates the charger LED 1 second after the charger is connected (if all is well). See this article for more info.

I hope all worked out well and, again, if you can, please let us know what the problem turned out to be and how it was fixed. Best Wishes!!

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Tiffany Bond sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 12

Son 30 gün: 51

Her zaman: 9,989