Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1472 Soru Tümünü görüntüle

Battery not recognized after sata cable replacement

I have a Mid 2012 MacBook Pro in which I recently had to replace the sata cable. I was getting a blank white screen and no hard drive was showing to boot to. I had a colleague of mine, who previously worked at Geek Squad with Best Buy, replace the sata cable for me. When I gave him the laptop, the battery worked fine, the only issue was the hard drive was not showing. After he replaced the cable, the computer booted up fine and everything in regards to the hard drive was working. However, the battery was not showing as active or available.

There is a {X} symbol on the battery when logged in (top right corner) as if it is not connected.

Things I've tried:

- Known good charger (same result)

- New battery (same result)

- SMC reset (I performed the keyboard command but I'm not sure how to tell if it was successful or not)

- The battery indicator on the left side of the laptop does not light up at all

I would like to add that about 2 years ago I did have water spill which affected the firewire port (which I never used), but it still worked after that with no issues for 2 years.

Any help would be greatly appreciated.

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Try disconnecting the battery indicator; this can interfere with the battery data lines if liquid damaged, preventing the battery from being recognised.

This is unlikely to resolve the issue though I’m afraid. Sounds like your colleague disconnected the battery with a metal tool, or shorted it another way, which can send battery voltage to the SMC through the data line, killing it. Common issue and hear this happen a lot on the forums. Only solution is replacing the logic board or solder a SMC from a donor board.

Bu yanıt yardımcı oldu mu?

Puan 2
Yorum Ekle

Yanıtını ekle

Matt Surman sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 1

Her zaman: 83