Ana içeriğe geç

The Motorola Moto Z Force (XT1650) is an Android smartphone developed by Motorola. It also is known as the Moto Z Force for markets outside the US and has been available since July 2016.

31 Soru Tümünü görüntüle

Phone won't power up or charge

Hi, a buddy of mine recently gave me his old Moto Z force, and i'm hoping to fix it up and use it. The issue is that the phone won't charge or turn on at all. No charging lights when plugged in. I tried the charger in his moto and it worked fine, so no issues with the charger. Apparently before the phone broke, when he would charge it, the battery would get very hot, but one day it just quit on him. He brought it into Verizon, and they told him that they thought that it was a battery issue, and that the battery needs replacing. I just want to see what people's experience is with this issue. I'm just hoping it was just a battery issue and nothing too major. but the phone was free, so i'm not afraid to throw money at it to fix it. Thanks a ton!!


Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
5 Yorum

hey there im having the same issues only that when I place my battery pack on the back of the phone, to charge the phone ,the screen prompts and shows me the device is fully charged , but still will not turn on .


My motorolla g3 turbo edition won't turn on when i presses power button or volume down it just vibrate and nothing happen just blank screen full black. This things happen when i replace battery, when i replace the battery and connects charger it show 65% than i disconnects the charger and fit the screen and than try to turn on but it won't just vibrates…..please help…


Hi my sister has the moto phone and for 1 year it stopped charging no matter what charger we had it would not turn on even tho all the chargers worked for my fire stick tablet i just want to say it WONT CHARGE!!!!!!!! so plz fix it and plz if you see this review reply



Over 20 years’ experience with Motorola phones, and this is the first time I have ever seen a Motorola phone do anything like this!

* Droid Moto Z Force (2) shows a charge under 15% (dropping precipitously from charge numbers in the 30%+ range a few minutes earlier).

* Then, when plugged into the (factory-provided) turbo charger it shows a “lightning bolt” in the upper border of the screen, supposedly indicating that it is plugged-in and receiving a charge.

* Then, this ($700.00) phone — which has been “babied” and doesn’t have a nick or a scratch on it — CONTINUES to DISCHARGE while plugged-in!

Reboots (first cold and then warm) did not improve this problem — eventually, unplugging and re-plugging the USB-C cable several times did rectify it — for now, that is.

I suppose I am “lucky” to only be experiencing this problem after about 3 years of owning and using the phone — but this problem speaks to the UTTER FAILURE of Motorola to maintain their previously-excellent manufacturing standards.

(As another person posting here wondered, “intentional?”)

I will buy a newer/better cable first and try that. If that fails, I’ll find a capable independent phone repair shop to replace the battery and check the connectors (as indicated in various solutions posted here) — but I think THIS IS THE LAST MOTOROLA PHONE I’LL EVER BUY.



I have gone the route of replacing a battery and screen on a previous (Motorola Razr Maxx) cell phone.

Took two attempts to get all of the connections right and the unit fully-operational -- scared to DEATH that I would ruin the unit!

Going to a "pro" this time b/c I do not want to experience that fear again.


Yorum Ekle

3 Cevap

Filtre ölçütü:
Seçilen Çözüm

To me this does sound like a battery issue, I'd take it in for a battery replacement. It looks like your battery just overheated and gave up. Also check the charger as I once plugged in a bad charger and it pretty much melted away. Anyways hoped this helped in some way.

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle
En Yararlı Yanıt

U need to replace your battery. Mine started to act funny and it would randomly shut off even though it showed I had a charge. It was all over the place - 30, 50,80, 15, 10,95%. It didn't matter. After it shut off it would display zero charge when I hit power button. As soon as I put it on charger it would show whatever the previous charge was. So for example if it showed 30% before it shut off, it would show that after I put it in charger for a little while. But if I removed charger and turn back on it would go on at first, but then shut off not long after. It git progressively worse and fast. It got to the point where I had to keep it in a charger or have a battery pack on it in order to use it. And after a while it seemed the battery pack wouldn't even revive it only actual charger. Anyway I did factory reset, conditioned battery and nothing worked. I found this site and ordered a battery kit and I just replaced my battery and it works great. Very happy because I basically have a new phone now. As far as the replacement procedure, I suggest u take your time in order to prevent damage when u take it apart. I do have some more tips that might help, if u are going to do it. Just let me know. Good luck

Bu yanıt yardımcı oldu mu?

Puan 4

2 Yorum:

What other tips do you have? My LG G4 just went completely dead. I already got a new battery, installed it and plugged into the quick charger and wall outlet. Did not get a power light or a screen that shows it is charging. Is it possible that the battery in it got hot enough to overheat the interior and melted something so now nothing works. Won't charge and won't power up. Maybe the new battery is DOA also. This phone has been around since 2016 and I guess the batteries could lose their power if they sat in a warehouse too long.


I have also tried several different charger cords...all are LG cords and plug into this phones port. The new battery is an LG OEM battery. There is no way to reboot or do a factory reset of the phone when it will not even power up.


Yorum Ekle

I fixed mine. Here is my thought process to troubleshoot. Battery charges to 100% but no buttons work, holding them for ten minutes does nothing. So we know the battery is good and the screen is fine. So whats left? Either the mobo is fried or it's mechanical. I opened it up using the directions from the iFixit website. I found the ribbon connector to the power button, popped it loose and re-seated it. Voila! Phone works! It's a 3 year old Droid Moto Z Force XT650-2. All those guys that have the same problem, try this. It's a tiny matchhead size connector and they get loose or corroded over time. It's been a month, still working. By the way, this is my second screen and second battery. The quality control for this phone is horrible. Or deliberate. Mine, like so many others, lasted a year and a day. Coincidence? I dont think so!!!

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Blayne Girard sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 3

Son 7 gün: 8

Son 30 gün: 48

Her zaman: 11,497