Ana içeriğe geç

iPhone 6 dead after touch ic repair


I got a iphone 6 in that worked fined except for touch issues. Each time the touch came unresponsive, i only had to twist the phone a little and it worked again so i figured it would be the touch ic. I’ve replaced many touch ic’s already it not had a problem afterwards but this time the phone is dead. Like completely dead. I only conected a new charging port, a new screen and a new battery and plugged it in but it doesn’t get hot or use any amps at all. I replaced the ic once more in case it would have a short or something but still the same thing. Any ideas where to look for?

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Start by checking the power rails (PN5V7_SAGE_AVDDN / PP5V7_SAGE_AVDDH / PP1V8) that supply the Meson IC to see if there are any shorts. While you’re at it, check the rails for the Cumulus IC as well (PP5V1_GRAPE_VDDH / PP1V8_GRAPE).

If that looks good, then you can boot the phone without the MESON IC (U2402/the black one). If the issue is with the IC (was it reballed or replaced?), it should boot fine but will not have touch.

If none of this works, then the problem can be anywhere. Check the main voltage rails (check PP_BATT_VCC & PP_VCC_MAIN)and work your way from there. The risk of any BGA repair is applying too much heat. When that happens, you can get solder ball explosions from underfilled IC’s in the area.

Bu yanıt yardımcı oldu mu?

Puan 2


I checked all the power rails for Meson IC, Cumulus and no short. I checked the main voltage rails and no short. And i removed the Meson IC but the phone is still dead. I did find something interesting though. I hooked up a new battery, new charging port and a new lcd to try the phone. I checked the battery beforehand to be sure it was charged and it had 53%. So after that i had tried to turn on the phone i removed the battery again and plugged it into my battery tester and it didn't even recognize it like if it would be too dead. I have a battery activator so plugged it in there for a few seconds and then tested it again and now it showed 53%. I tried it on the phone again and the exact same thing happened. I tried more new batteries and the same thing happened to all of them. It's like the phone damages the batteries that they required to be plugged into the activator to work again. Another thing that i find interesting is that there is absolutely no usage in amps when i plug the phone into the charger.


Yorum Ekle

Sounds like something you'd have to look and understand the board schematics of. Sadly I’m not enough of an expert in that area, but think people like Louis Rossmann would be. That way you can use a voltmeter to figure out what is receiving power, how much power, and how much it should be receiving. But this would be more difficult considering no power is going in at all, by which point I would suggest doing some continuity testing to make sure things like the battery and charging port are even connecting properly.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Hernando Berg sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 3

Son 30 gün: 15

Her zaman: 508