Skip to main content

Second generation of the Toyota 4Runner.

32 Soru Tümünü görüntüle

Why aren't my tach and speedometer working?

I just bought a 92 4runner that needs a fair bit of TLC. It runs well, but there are a few things that I'm leary of. 1st, I need to know how I can fix my speedometer and tachometer (note, only those two dont work. The rest of my gauges work fine).

2nd, (bonus question), how would I go about reconnecting my ebrake cable?

According to the previous owner, when he had the engine swapped (it was the 2.9, but he swapped it for the 3.4), the mechanic simply didnt reconnect the sensors for the tach/speedo. Additionally, by what he said, the ebrake was disconnected for some work he did himself, he just never got around to putting the cable back in.

Just in case it makes a difference, it's a 5 speed manual, 4x4. Anything anyone needs to know, just ask.

Answered! View the answer I have this problem too

Is this a good question?

Puan 0

Yorumlar:

Have you reconnected the sensors?

by

I suppose I should've clarified: I was more so asking for info on their location. I've looked and cant find them.

by

Add a comment

Android Tamir Setleri

Yeni bir ekran veya pil, bir tamir kiti kadar yakınında.

Hemen Alışveriş Yapın

Android Tamir Setleri

Yeni bir ekran veya pil, bir tamir kiti kadar yakınında.

Hemen Alışveriş Yapın

1 Cevap

Chosen Solution

I am not so sure about a single sensor. Your Speedo and tach are on different “sensors.

RPM signal system

Crankshaft position and engine RPM are detected by the pick–up coil installed inside the distributor. Crankshaft position is input as a control signal to terminals G1 and G2 of the engine control module (ECU), and RPM is input to terminal NE.

 (6) vehicle speed signal system

The vehicle speed sensor (speed sensor), installed inside the combination meter, detects the vehicle speed and inputs a control signal to terminal SPD of the engine control module (ECU).

So check your ECU connectors

The attached wiring diagrams etc. should also help you to get started with a better diagnosis.

Document:Document:

Was this answer helpful?

Puan 2

Yorumlar:

So if it's a sensor issue for speed, I'd have to replace the full combination meter?

Could it possibly just be that he bluffed and it's a bad gauge cluster? I've read this year seems to go out between 175k and 190k. It's at 204k.

My fuel, temp, oil, and battery gauges all work. But excluding those, a dying cluster could affect the tach as well, could not it?

by

Yes sir of cause it can. Check the documents I've attached. It will show you how test the cluster with a multimeter etc.

It is always tough to narrow things down when someone else made changes to the system etc. So you really have to check carefully.

by

Add a comment

Add your answer

Synth Wolfe will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 8

All Time: 51