Ana içeriğe geç

6s No touch after fixing VCC main short

I checked in an iphone 6s for a battery and screen replacement, but found there was some very minor water damage and a short on VCC main next to the cpu. I located and corrected the vcc main short after cleaning the water damage using a dc power supply, and the phone is now powering on okay.

However, i notice that with aftermarket screens i get no display. With an oem screen, i get display but still no touch. I found an open line on the fpc connector at pin 39(pn5v7_lcm_meson_acddn_conn, which I'm not sure has anything to do with touch, but i saw Meson in the line name and thought why not check it out) and after some troubleshooting i replaced chesnut. I am now getting good diode mode readings on all pins as far as i can tell, but still no touch.

I then thought it could be an issue with the fpc, so i bent the pins in to try to make sure they're all making a good connection, but my issue remains the same. I still have a feeling that the connector may be the problem, but i personally always seem to mess up repairs when i attempt replacement so i would like to be at least reasonably more confident that is the source of my problem before attempting to do so. Does anybody have experience with an issue like this or any tips that may be of help?

thanks in advance!

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

1 Cevap

Filtre ölçütü:

Have you looked around the touch ic.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

townsenj2000 sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 Gün: 0

Son 30 Gün: 1

Her zaman: 28