Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

iMac Intel 27" EMC 2309 (Late 2009, Core 2 Duo 3.06 or 3.33 GHz) ID iMac10,1, EMC 2374 (Late 2009, Core i5 2.66 GHz or Core i7 2.8 GHz) ID iMac11,1

498 Soru Tümünü görüntüle

Late 2009 iMac 27" memory issue

I had a dying Seagate hdd starting to fail, I replaced the hdd with a ssd.

I preloaded the ssd with High Sierra. I booted up the iMac with the ssd as the boot drive, no problem.

hdd removal, and ssd install went great, on restart I am now missing half (two 4gb ram sticks memory) of my 16gb. Two of the slots show “Empty”

Regardless of which slots I put the memory in (ie, i remove two sticks from the left slots and start up, the right two slots show 4gb each.

Moe those sticks t the left slots, restart, the right two show empty.

Now I place the first two sticks in the left slots with the sticks i removed, restart, they show up a two 4gb memory.

Move them to the right two slots, they show as two 4gb memory.

No place the two sticks back in the left slots, and they show empty. Remove the right two sticks the left now show up.

Any configuration of more than two 4gb sticks shows only two “full” slots and two empy.

So the ram sticks are “good”

The slots are “good”.

I re-initialized the ssd and installed El Capitan (what the iMac was running on prior to switching the drives.). No change.

I did the PRAM/NVRAm and SMC resets, again no change.

I ordered two new sticks of ram, just to test the possibility of bad ram?

And on some forums it was suggested the HS update updated the firmware to “weed” out sub-performing accessories like ram, HD’s, etc.

Is it possible to downgrade to perhaps the original version of the EFI firmware?

Or any other suggestions.

I have owned this system since new, and other than a Apple hdd replacement 5 years ago and the hdd issue recently it is a great machine.

iMac (27-inch, Late 2009)

2.8 GHz Intel Core i7

16 GB 1333 MHz DDR3 (16GB being recognized)

ATI Radeon HD 4850 512 MB

Any assistance, ideas appreciated.


Update (05/03/2019)

Dan. I used the term broke, because that is what it did.

That being said, Apple does this to ensure that “it just works”, I understand why they do it. And despite my searching BEFORE I did the upgrade, a broad search of “Will a Late 2009 iMac 27” i7 run High Sierra?) The results were your usual mix of yes and OMG horrible, etc…

But the rationale reviews were positive.

Macs have been able to different capacities over and above “Official” Apple specs. As well as variations (speed) of a type ram stick, usually with a little or no improvement, and usually a hit on speed.

I did assorted hardware tests on the system (that is how I narrowed the issues i was having to the Hard Drive).

Memory was fine, as were all other pieces parts.

After the upgrade and ssd install, I ran hardware checks and the memory the iMac could see all came up as good.

I did not spend a lot of time initially looking at the ram sticks themselves. Since they all checked out as OK in the assorted tests. Not until i started digging, did i see mentions of the MacOS/firmware disabling what i called sub-standard or approved hardware (like a charger cable, charger, memory, etc.

That is when I looked more carefully at the ram stcks, and noticed the “speed” difference. As these were installed at an Apple store, I, again was not super concerned. More research made it evident that while yes the ram sticks were functioning and would most assuredly work great on a appropriately specced machine, these were NOT appropriate for my iMac.

So I ordered new Crucial sticks, specced for this iMac.

I am not angry, I am disappointed at the Apple store. and Apple for the “fix’, Perhaps i am not tech savy enough to find and read the warnings for upgrades. Which is why I wait awhile before doing these things.

I appreciate your input. Mark

Advant Memory

Block Image

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2


Take out your RAM and take a snapshot of the labels we only need one per set, unless each is different. Adding images to an existing question

You may want to re-install High Sierra from the installer again as it also had a firmware update within it. When you did the OS install the first time did your system restart and have a long beep tone? If not you need to re-install.


Hi Dan, upon ssd install and start-up, it started up fine. Ran fab. If not for the checking in "About This Mac" window I would not have noticed the memory issue so soon.

The High Sierra install did upgrade the firmware to the latest available, and as I can swap out the ram sticks pretty much any slot, any two sticks and it only reads two sticks. I am leaning toward an APPLE software/firmware "fix".

Even though the 16gb is what the Apple store installed when they replaced the hdd a few years back. It seems I have; 8 GB 1333 MHz DDR3. It is supposed to take 8 GB 1066 MHz DDR3.

New Ram?


Are you saying the 1333 MHz SODIMM's are suspect? What are the other set?


The Apple "update/fix" broke the memory is the simplest answer.

Installing MacOS High Sierra updates the firmware. One of the fixes is to do a check on components/accessories to make sure sub-standard' hardware won't run.

This "fix" is so the MacOS's run without any issues. In other words, if it is not officially supported/approved by the hardware check it won't allow it to run.

Now that I have done the firmware upgrade I am (so far) informed i cannot go back, or downgrade to a firmware version that allows the memory to work.

Apple has done this previously.

The memory works, the iMac will not recognize more than 8GB A system that is specced for 1333Mhz sodimms will work great, as they did in the iMac prior to the MacOS install.

The specced ones are 1066Mhz sodimms.

I could be talking out my butt here, but as i have looked and attempted a bunch of other fixes, I will try this and keep reading and searching.


Yorum Ekle

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

1 Cevap

Filtre ölçütü:

Lets, clarify things a bit. As you can see here Install memory in an iMac - 2009 27" iMac So Apple acknowledges it can support it so that's not the issue.

Apple wasn't stepping on your toes intentionally. They are not checking components/accessories or for sub-standard hardware. Others are not encountering this problem.

You do have a hardware problem the question is which side? The RAM you have or the system.

As you never supplied any info on the RAM I can't even check it out. You also didn't tell us which slots if a given set of slots are failing. So at this point I think you'll need to find someone locally to help you.

Bu yanıt yardımcı oldu mu?

Puan 0


@danj I apologize I posted an image of the old Ram.


I am not saying they did anything malicious, I understand why they do these things (and it is possible it has nothing to do with the problem. As I may or may not have stated, an Apple Genious told me this and I read it online. (And of course, we all know everything online is 100% factual and true ; )

That being said. that all four slots/Banks work, but not with all four sticks (or even three) when they were working fine before. Now it is possible I may have done something to the ports when I did the SSD install.

I installed Crucial CT4G3S1067M.M16FKD 4GB DDR3 -1066 1,5V SODIMM CL7 new in the package sticks from Crucial. All that checks out when I ran MemTest86 as a boot drive.

I also put the ram in another computer, ran appropriate tests, and again they come out OK.


Also all four slots work/don't work (If I explained the situation correctly) so that is a non-issue?

The local Mac store Simply Mac is an awful facility. I have tried to use them in the past and sadly the manager is a liar or just clueless.

I can put two sticks of RAM either original or new in any two slots and they will work.

I can put any of the four new 1066 sticks in and Bank 1 will work, but Bank 0 will not.

If I remove Bank 1 sticks Bank 0 will work, I put Bank 1 sticks back in and they will not work just Bank 0.

I try with just three and it reads only the "pair" in the same bank 0 or 1.

Speaking with PC repair shops (we have only the one Mac Repair shop) Closest Apple store is two hours away. And pretty sure the answer will be "time to upgrade to a new Mac"

So to sum up:

HD failure

Replace HD

MacOS upgrade one version

SSD works great

iMac sees only 2 slots

Possible causes:


Touching or damaging some resistor/part during SSD installation

Firmware update during OS update



Yorum Ekle

Yanıtını ekle

mark ray sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 5

Son 30 gün: 15

Her zaman: 171