Ana içeriğe geç

Eşyalarını Tamir Et

Onarma Hakkı

Parçalar ve Aletler

Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1466 Soru Tümünü görüntüle

Battery not connected consistently

Hey there,

I got a problem with my Macbook Pro Mid 2012 recognizing its battery. At some point while using it it suddenly shuts down and won’t start again unless I plug in the power adapter. In this case system stats show that the battery is not being recognized. My first attempt of solving this problem was to pop the bottom cover off, disconnect and reconnect the battery cable from the logic board - pop the cover back on and suddenly it starts working again as if nothing happened.

Unfortunately not for very long periods of time. Sometimes hours, sometimes days. This behaviour is very consistent. It shuts off, I reconnect the battery, it starts working again for a limited period of time, it shuts off again and so on.

Then I ordered a new battery, the old one was kinda weak anyways. But the new battery didn’t solve the problem either.

Here are some coconut battery stats (this is with the replacement battery) directly after the disconnect reconnect game.

Block Image

Block Image

Some more information about the history of this laptop: I bought it used and non functioning from a friend (suddenly stopped working and won’t turn on again) for a very low price so I tried my luck, sent it to a repair company in Berlin to have them have a look at the logic board. They replaced the display cable and the charging electronics (that’s how they called it on their paper). I didn’t mind cause I got a working macbook for a good price including the repair that lasted me about 4 years until now. I put in more RAM and a SSD and for some time I used a SATA3 adapter to use an additional HDD instead of the optical drive. sooo…

Any help how to proceed further will be much appreciated :)

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1

Yorumlar:

Tough one. Just a hunch, please press the battery test button both when it is running and when it shuts down and let us know your results.

tarafından

when it is running the test button functions normally, when it shuts down the button appears to be dead (no reaction at all)

tarafından

Yorum Ekle

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

Nintendo Switch Kit'leri

Oyuna geri dönmek için hızlı bir düzeltme

Switch Kit'leri Satın Al

2 Cevap

Filtre ölçütü:
En Yararlı Yanıt

I wish I could be helpful but there’s not much to work on here. Battery data are more than good and a repeated behaviour with two different batteries points to the logic board. There’s not much one can speculate without going through schematics and thorough testing..probably something along current sensing but it wouldn’t be a typical DIY repair.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

Yeah, I understand that. I'd really like to understand what is causing the problem to be honest, even if I couldn't fix it myself. I was hoping that there may be other hardware involved that could be swapped out more easily and less costly than the logicboard. But thank you very much for your answer still!

tarafından

@pinguur There's plenty of things in this world I'd like to know better but time is limited and things are complicated. If you have a passion and lots of patience you may end up finding out what's wrong with your board one day. If you need it for work or study though, I'd warmly recommend to pay someone who knows the job or just replace the board as there's nothing in between board and battery one could replace.

tarafından

You're right, good thing is I don't really need it to function in laptop mode at the moment - and it works when its plugged in. Chances are high of course that I won't find out whats at fault and some day I need to get it repaired professionally.

tarafından

Yorum Ekle

Does the issue go away with the original battery installed?

If multiple batteries are behaving in the same way, the issue is most likely not with either battery, however if you’d like to try another replacement battery, you can contact iFixit’s Customer Support and provide them with the order number and the same details provided here.

Your issue could be a caused by a few other components, namely the logic board, MagSafe board, or could even be a software conflict.

To rule out software as a cause, you can try performing these steps to see if the issue goes away:

  1. Repair and verify Disk Permissions
  2. If you are running MacOS El Capitan or newer (MacOS 10.11+), please follow this guide instead of Step 1
  3. Reset the NVRAM/PRAM
  4. Reset the SMC

Otherwise, if the issue persists after performing these steps, then the issue could very well be other hardware.

I hope this helps!

Mac OS X Görseli

Kılavuz

How to verify and repair Mac OS X Disk Permissions

Zorluk:

Çok kolay

5 - 10 minutes

Mac OS X Görseli

Kılavuz

How to Run First Aid with Disk Utility

Zorluk:

Kolay

15 minutes

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

no, the original battery and the new battery behave in the same way. I performed your recommended steps but unfortunately it didn't help. Still the same problem. Is there anything else one could do to pinpoint the possible reason more? With swapping the logicboard being the last option to try? Any kind of test to run maybe? I'm just guessing and I suspect that my capabilties are kinda limited but if there's anything to try before sending it in I'd like to try that.

tarafından

Yorum Ekle

Yanıtını ekle

pinguur sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 3

Her zaman: 27