The screen is on but it's not showing anything

Took this Samsung NP350V5C-S0QAE second hand and wanted to factory reset it. Pressed f4 whole it was showing the Samsung logo then it showed a black screen. Tried turning it on and off, didn't work. Tried removing the pour source, pressing power button for 1 minute then connecting the charger and turning it on, still the same logo then black screen. Tried to press f4 again, nthn. Turned it on and left it for a couple of hours, nothing. Tried pressing ctrl+win+shift+B incase it was an app that was doing all this but still nothing. I also tried f5 and f11 and f4+f7 but nothing worked.

I can hear the laptop running and there is light coming out of the screen and all the lights are working but the screen just keeps showing the Samsung logo then turns all black / dark blue. How do I fix this?

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

1 Yorum:

Hi @saltyboi ,

What OS is installed?

Can you get into BIOS with a working screen?

Try starting the laptop in "safe mode" (search online for {insert OS} safe mode to see how to do it) to see if you get a display.


Yorum Ekle