Ana içeriğe geç

X in battery icon in menu bar. What's up with that?

On the above machine, now I get an X in the battery icon instead of an outlet or thunderbolt. I tried another battery on it. The swap showed the thunderbolt for a little while and then went back to the X.

I don't think that it is the battery since it happened to two batteries at the same time. My guess is that it could be the DC to DC board. BTW, the power adapter is glowing green.

Any suggestions to fix this problem?

Yanıtlandı! View the answer Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1

Yorumlar:

Thank you for the replies! much appreciated!

I went ahead tried the second battery again. It started to charge and then stopped at 65% and went to an outlet icon in the battery icon in the menu.

I rebooted the machine to get into the charge cycle. However, instead of it charging after the reboot, the second battery too had the X in the battery icon.

I went online and looked at a couple of web pages that discussed the problem. One of the suggestions, was to FLEX the battery area that (for lack of a better word) holds the battery in the computer. After I did this, the machine started to charge the battery. However, it went back to the X after charging it to 65%.

I had yet another battery. I once again flexed the battery area and put in the third battery. I was able to get this battery to recharge from whatever percentage it was on to 100%. I guess the combination of the flexing of the battery compartment and a conditioned battery did the trick.

by

Glad you got it fixed Yuri. Please post your comment as an answer and "Accept" your own answer this way it can be archived and might help the next person with the same issue. Thanks.

by

Well, I thought that I had it fixed! However, since the last post, I had the same issue with it again. I even went ahead and changed the DC to DC board on it. Again, it started to give me a percentage and then went back to the X icon in the battery menu. So, it stands this way, now ALL my batteries show an X when I put them in and also, I changed the DC to DC board at least twice! I am going to try another DC to DC board. Any thoughts on what I can do to diagnosis this problem?

by

Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

It's either a strange coincidence that both batteries are bad, or your DC In board might need to be replaced. I would try to obtain another battery which you know for certain is in working order and test with that. If you get the "X" again, then replace the DC in board. Does the machine boot without the battery and just the power supply plugged in? Remove the battery and boot with power supply only and chime back in and let me know the results.

Bu yanıt yardımcı oldu mu?

Puan 2

Yorumlar:

works without battery inside. I am still having this problem with the X icon in the menu bar. when I boot the machine without the battery inside the machine, the X is still in the menu bar.

by

Yorum Ekle
En Yararlı Yanıt

You can easily check the output voltages on the connecting pins in the battery compartment using a multimeter. The two outer pins are ground, the inner ones should read something around 3,5 volts each. Be careful not to short anything.

Bu yanıt yardımcı oldu mu?

Puan 3

Yorumlar:

I know this is an old peice of tech but I’m a collector and I have reset pmu swapped dc to dc board and swapped batteries but nothing but here’s where things get interesting you said the two outer pins are ground only one of mine is grounded should I solder a wire to it and ground it and also The pin that was next to it read 0 volts and the one by the pin that actually was grounded read about 2.25 volts I’m really frustrated about this and I just want to be able to use it without the plug and also why would the dc in board have anything to do with this the dc in board should be working if the thing powers on right

by

Yorum Ekle

Yanıtını ekle

Yuri sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

Her zaman: 827