Laptop won't turn on, power light on for 6 seconds, no video/anything

Actually my model is C55-B5101. When I press the power button it turns white for 6 seconds, then off for 2 seconds, y then on again for 6 seconds, and then it just turns off completely until I hit the button again. Fanless laptop. RAM looks fine and clean. I f I turn it on without the charger it blinks instead for 5 seconds (every 0.5sec) and the off.

I searched that the 5sec blinking if because of the battery not properly charged, maybe need to replace it, but when plugged in it should work and it doesn’t.

How can I check if the MOBO is damaged? or what can I try? no CMOS battery either, can that cause the not turning on?

Bu soruyu yanıtlayın Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1

Yorumlar:

Often, if there's an issue with the hardware. The pc should either beep or sometimes, some lights go on/blink. These lights can be numlock, capslock or a combination. Can you see any such thing?

As far as i know, a CMOS battery that is not installed should not prevent a computer from booting. But BIOS settings and time does get reset when power is lost

tarafından

Do the following to check to see if you have a bad battery, bad charger or maybe a static buildup.

1. Unplug the charger, and remove the battery.

2. Hold down the power key for 1 minute. This does a static buildup dump.

3. After 1 minute, put the battery back in. Turn on the computer. If the laptop turns on, that means the charger is bad or going bad.

4. If the laptop still doesn't power on, take out the battery again. Hold down the power button for another minute. Then plug in the charger. If it turns on, then the culprit may be a bad battery.

5. If that doesn't let you know the problem, you have other more serious issues, like possibly a bad motherboard, bad charger jack (loose/bad connection inside), BIOS problem, etc.

tarafından

@maximc I read online about the num lock or caps lock lights, but neither turn on, only the power light and the battery light which is on when I plug the charger.. There is no beep

tarafından

Try @fish1552 s comment, otherwise, try sourcing or lending a known good charger. I had an acer laptop once with similar issues. Another charger fixed it.

tarafından

Yorum Ekle