Ana içeriğe geç

2.2 GHz (Turbo Boost up to 3.4 GHz), 2.5 GHz (Turbo Boost up to 3.7 GHz), or 2.8 GHz (Turbo Boost up to 4.0 GHz) quad-core Intel Core i7 processor with 6 MB shared L3 cache.

595 Soru Tümünü görüntüle

Internal SSD not recognized on 15" MacBook Pro retina retina

“Internal SSD not recognized and not working on 15" MacBook Pro Retina”

Hello Intelligentsia

 I have a 15" MacBook Pro from mid 2015 and had some issues after installing past high sierra (not sure really if I had actually installed Mojave because I try to avoid all the “Upgrades”). At one point I had a frozen screen and did a very unadvisable hard reset.

When I powered on I had a flashing folder. I used recovery mode and found to my dismay that there was no SSD recognized only the Disk 0 and the Mac OS X Base System, I then installed the OS from recovery which happened to be the base system that came with it in 2015 - Yosemite.

I do not yet know how to use the Carbon Copy Cloner stuff so I do not want to do any erasing or formatting of the drive.

I could not access the drive in recovery mode with the disk utility because it would not show up. The only thing I see is "disk0" and under that, Mac OS X Base System. I also tried to use a boot loader to get “sierra” and this has not worked in any way nor can I get the disk Util to show the ssd

What do I do to get my Mac to see the SSD? I imagine some simple unix type commands in the terminal can [fix / repartition/ fix boot loader/ rebuild the master boot record]?? As I imagine this was just improperly unmounted?? I am hoping some high level Admin type people read here and answer questions. I have an external SSD hooked up so I at least have the thing working and stuff but want to get my data and also fix my internal SSD issue before upgrading to a better working data storage solution.

Thanks in advance to the engineers who this is an easy question for!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:

Sounds like issues happened while installing an operating system update.

I know saying this is a little late for this issue but for future Please make sure to backup your computer before upgrading operating systems. Now that that’s out of the way lets see what we can do.

First things first, lets try to get your data off that ssd. I would recommend using a data recovery tool (below are two links) as their cost (50-100) is much less than the 600-1500 you could potentially spend with a data recovery service. If your data is highly valuable go with the data recovery service, it will save you time and a troubleshooting headache.

A list by Tech Radar on the best data recovery tools in 2020

'''Stellar Data Recovery Professional for Mac Tutorial'''

Assuming there is nothing wrong with your ssd aside from weird formatting issues, you can run data recovery software without worrying about damaging your Data or SSD. However if the SSD is failing, you might only get a few attempts at this, and with each successive disk scan there is a possibility to loose a random percentage of your Data permanently.

So, if you go down the path, don’t rush, take your time and make sure you are scanning the right disk with the correct settings

These scans can sometimes take days so make sure your computer is placed somewhere it will be able to be plugged in, and not touched until the scan is over.

Once your data is off the computer, I would recommend taking your laptop to the Apple Store for a diagnostic (Genius Bar appointment). They provide these for free to any customer. They may be able to help you diagnose your Mac’s issue and help you reformat your drive right there (if there isn’t a hardware issue, any software troubleshooting is usually free unless they tell you otherwise).

I hope this information gives you a direction to go, Feel free to comment if you have questions.


Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Hey David- thanks for the answer. my comment was to long so I posted as an answer.

I’ve seen how so many others have had this very same issue but yeah securing the data is number one and then all that recovery stuff comes second. I was hoping there might be a way to repair the master boot record or what ever this flash SSD is using to boot this thing up. I’ve also heard of others fixing the partitioning system and coming away better for it.

I strongly feel that there is some kind of way to fix the drive as it relates to directories and partitioning and its own boot loader due to the way it was improperly unmounted. One guy advises getting into the open directory on the command line and moving the [mbr cache] but when I open the terminal in recovery mode it is at /private/var/root and I don’t think the commands are valid to navigate to the volumes/Macintosh\ hd and all that.

I would like to boot into Single user mode but it doesn’t seem to boot up holding cmd+ s not sure why, either that or is taking way too long.

In single user mode I could use [fsck] commands to fix the drive using whatever commands are there. I also tried to have the mac default boot up natively to Single user mode but in command line typing: [sudo nvram boot-args=”-s”] I get an error msg after typing my password…

Anyway first thing is to get the data to make sure it’s safe…

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Mikhail D'palm sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 2

Son 30 gün: 13

Her zaman: 187