Ana içeriğe geç

A1708/EMC 3164 — Released June 2017, this entry-level MacBook Pro retains its traditional function keys (as opposed to the OLED Touch Bar).

560 Soru Tümünü görüntüle

Battery not charging after replacement

This weekend I replaced the battery in my MacBook Pro with a new ifixit battery. The MacBook had worked fine until recently, when it suddenly stated that the battery was not charging and needed replacing. Following on from this, it ran exceptionally slowly and would not boot at all at times.

I have replaced with a new battery, and it now turns on just fine (after an OS re-install), but is still saying that the battery is not charging. It now lists the following:

  • Fully charged: No
  • Charging: No
  • Full Charge Capacity (mAh): 4698
  • State of Charge (%): 1
  • Cycle Count: 0

Could it be the new battery has an issue? Any advice would be kindly received.


Update - CoconutBattery image as requested -

Block Image

Block Image

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 4
2 Yorum

While you have some on the needed information I need to see a bit more to figure this out.

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question


Hi Dan, have downloaded the app and added the image - hope this was what you needed to see


Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm


Followed up with ifixit support, who believe the replacement battery was faulty, so kindly sent out a new kit.

Have installed it today, and the mac is now working and charging properly :)

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle
En Yararlı Yanıt

Could you have damaged the battery data cable or not fully secure it? I would start there

Block Image

If that is in good order, I fear the charging logic needs to be investigated on the main logic board.

Bu yanıt yardımcı oldu mu?

Puan 2

7 Yorum:

Hi Dan,

I will attempt disconnect and reconnect the battery cable. Do not believe it was damaged during disassembly or re-assembly, but it could be the cable itself as this does not come with the replacement battery (needed to use the old cable), and this is exactly the same error I had prior to changing the battery (could be the old battery was not actually the problem?)

I presume the screenshot shows that the new battery itself is absoutely fine?

If it is the cable, I will order a new one and see if this resolves. Out of interest, what are the next steps to investigating the charging logic on the main logic board?


@Richard Crampton - The CoconutBattery results is perplexing!

Some of the data which comes from the onboard micro controller within the battery (the little logic board attached to it) is finding its way to the SMC services (Like the temp 19.3℃). But for some reason the current charge is zero!

I would start off replacing the cable and then see where you are. If that didn't alter things then its something within the logic board charging logic.


@danj thanks for the feedback. Interestingly, CoconutBattery is also reporting that the new battery is 1,281 days old - would that be correct? Not sure if the batteries fixit sell as part of the kit are refurbished (which would make sense), or if this could be related...


@Richard Crampton - iFixit does not sell used or refurbished batteries!

Did you replace the cable?


@danj My apologies, I did not mean to cause any offense! I am waiting on the replacement cable to arrive. The question was more around the fact that CoconutBattery is showing the new battery as follows (as per my screenshot):

Manufacturer: DSY

Manufacture date: 2017-06-12

Age: 1,281 days

Will see if that changes at all with the new cable once it arrives.


2 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Richard Crampton sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 16

Son 7 gün: 73

Son 30 gün: 293

Her zaman: 6,864