Ana içeriğe geç

The 2013 revamp of the desktop Mac series known as the Mac Pro.

115 Soru Tümünü görüntüle

PFM006 & PPN001 error in diagnostics

I have an MacPro6,1, the 2013 year model which has the kernel_task going to 900% and fans at full speed. I’ve run the diagnostics tool and it came up with the following two errors:

• PFM006 - There may be an issue with the System Management Controller (SMC)

• PPM001 - There may be an issue with the power management system

The mac powers on fine, but is extremely slow. The SSD is cleared so no software is installed, running from Big Sur from an USB is also really slow.

I’ve opened up the machine and there was a lot of dust. Cleaned out a lot and have put it back together. No change. The water indicators I’ve seen on the boards are not red, hence there is no liquid damage from what I can see. Nor can I see anything weird on the open sides of the boards.

I’ve also done the SMC reset, didn’t help either.

I got the 6 core D500 model with 16gb ram. It also has some HDMI issues from time to time, having the screen flicker (like it’s not getting a propper connection); however using thunderbolt > HDMI works fine.

Does anybody know what I can do to resolve this issue? Do I need to replace the backpanel/PSU, or is there another issue which I can look at?

Block Image

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 6
1 Yorum

Were you able get it fixed? I'm having exactly the same problem as well.

tarafından

Yorum Ekle

6 Cevap

Filtre ölçütü:
En Yararlı Yanıt

I think I may have figured this out. It turns out my MacPro 2013 had a loose Mainboard cable. Make sure yours isn't loose. Attached is a photo.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 4

2 Yorum:

I didn't connect the same problem with the fact that yes I had dropped my computer twice in the last 2 days. I got the same error codes. Open the back and started pressing boards back in and cable connectors in and I really don't know which one I hit but all the sudden the 250% kernel task and super fan mode stopped.

Everything's working peachy. This has nothing to do with Clean My Mac or software... The fact that happened right after a software update let me believe it was a software problem but...nope.

Some connector was unseated.

tarafından

Lose cable was my problem. I thought my Mac Pro was dead. Thanks a lot!

tarafından

Yorum Ekle

When your system encounters an issue within SMC, SMC will push the system into CPU safe mode! Basically ramping up the fan and lower the CPU’s clocking which is what you are seeing with the kernel_task going to 900% !!

This is to protect your system from over heating and is an expected reaction.

At this point your logic board has a problem with one of the sensors voltage sense lines. This really requires someone with deep skills working on 2013 Mac Pro’s to fix your logic board which is a rare skill set.

I own one (which I love) and even I don’t go this deep. I would recommend you visit an Apple Store let them fix it as they have access to the parts.

Bu yanıt yardımcı oldu mu?

Puan 2

2 Yorum:

I was afraid of such an answer. No way to reset/re-program the SMC chip?

tarafından

@Paul Peelen - Nope! It is what it is.

Reprograming it to disregard the sensor is like turning off your fuel gage to your car just before you go on a long trip across the Australian outback with no fuel stops along the way, just not wise!

tarafından

Yorum Ekle

Had the same issue after replacing a MacBook 12 battery (2016). The cable leading to the keyboard and trackpad (replaced this cable too).

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

i have the same model. same problem. did u fix it just with a replacement cable?

tarafından

Yorum Ekle

Please is there a solution for this now ?

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Yeah, is there even a solution for this for in-home repairs?

tarafından

Yorum Ekle

Bonjour,

il y a un mois j’ai eu exactement le même problème avec mon MacBook Air 2013, sûrement cela provenait du MSC

Alors j’ai payé une brosse à dent et de l’alcool (méthyle) et j’ai nettoyé toute la carte mère délicatement, surtout sur la puce du MSC.

J’ai aussi brossé dans chaque port j’ai mis la carte au soleil pendant 2 heures j’avoue qu’elle était chaude et je commençais à flipper

Quand j’ai rallumé mon MBA au début il faisait ses caprices mais après il est passé bien sans problème jusqu’à aujourd’hui.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Please I have the same issues with the Mac Pro 6,1. Pls were u able to fix it?

Struggling with the pc here. I have done almost every thing but nothing seems to help issue.

Pls share if u have any update.

Thanks

Bu yanıt yardımcı oldu mu?

Puan 0

1 Yorum:

Did you check the cable which I posted on Oct 13, 2022 in this topic?

It looks like this cable can become loose over the years. Check that it is firmly in place. The cable can look like it's properly connected, but if you give it a push you may find it connects tighter.

tarafından

Yorum Ekle

Yanıtını ekle

Paul Peelen sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 9

Son 7 gün: 52

Son 30 gün: 280

Her zaman: 6,328