Ana içeriğe geç

2.6 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.2 GHz) with 3 MB shared L3 cache. Released February 13, 2013.

111 Soru Tümünü görüntüle

Battery or DC in Board?

Put in larger SSD, machine ran no problems. Now DEAD. No gong, no fans, nada zip. Did SMC reset, still dead. Tried different charger, still dead. MagSafe shows amber light. SMC reset turns it green, then goes back to amber. Removed battery connector and tried to start with just charger cable, no battery; still dead. There are 4 gold contacts on top of battery connector:

Block Image

I get ~3.25v on each side, total ~6.4V. I assume but don’t know that this is the total power from this battery. New replacement battery from iFixit has 11.21V. So the question is: Is it the DC in board that isn’t charging the battery, or the battery is no good? How can I tell? Can I test the DC in board somehow?

Many thanks!

Bu soruyu yanıtla Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
Yorum Ekle

2 Cevap

Filtre ölçütü:


I think the DC board is fine as the charger turns orange, which means the charger is detected. Seems like the battery has had it. Or you might have not plugged all the cables in properly. Please check all the cables are seated properly. You can also check when plugging in the charger if the charge level on the battery is rising. Also try booting without the battery.

Bu yanıt yardımcı oldu mu?

Puan 0

1 Comment:

Thanks! Surely there must be some way to test the battery but I haven't found it yet. This occurred after putting in the upgraded SSD. It ran fine for a while, so can't be a cable issue, plus only the SSD cable was detached and re-attached, no others. Tried booting without the battery connected (complex connector, non-removable battery for this unit), no boot. Can't check the charge level because I can't boot and see any battery monitor.


Yorum Ekle

Okie Magic works again!

I took it apart and checked the DC-in and logic boards for corrosion, burnt parts and such. Nothing. Cleaned VERY thoroughly around the MagSafe connector on the computer. Also scrubbed the pins on the charger side of the MagSafe and ran some alcohol through the spring-loaded pins. One of the pins seemed maybe slightly sticky?

During reassembly I saw a slightly oily film near the AirPort card (separate from the logic board). Took off the AirPort card and there was some similar fluid under that on the non-absorbent foam pad on the underside of the card. Cleaned that all up. Got it all back together, fired it up and it worked just fine. I have NO idea what I might have fixed or not fixed. System profile software says battery isn't even to 1,000 cycles yet and is in good condition. Problem solved, no idea exactly why, but can't argue with success. Better to be lucky than good.

Thanks all for your help and for being on this forum to help us less talented folks.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

Robert sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 1

Her zaman: 35