Ana içeriğe geç

Repair documentation and service information for Hisense televisions.

45 Soru Tümünü görüntüle

TV Backlight Turns On For a Moment Only

This is my first ever TV repair, I usually repair smaller electronics, so be gentle on a tv-rookie please :) I’m good with data circuits and DC power circuits, but I never had real experience with power supplies. Seen some vids, but never had one on hands.

TV: Hisense H55MEC3050

Docs I found:

Power supply schematic RSAG7.820.6106 Power Supply

Driver IC Datasheet

Main board rsag7.820.6392 (haven’t looked for schematic)

I have a multimeter and an oscilloscope. I watched a few vids and read a few guides on how to troubleshoot the stuff, so this is what I’ve done. Once I turn the TV on:

1) Backlight Enable line between power supply and main logic board - always 3.7V (driver IC datasheet says it needs 1.7V for enable or higher and below 0.8V to disable)

2) Backlight dimming signal is 98% Duty cycle 4.7V (according to driver IC datasheet, should work). So pretty much stable 4.7V there. Like this:

Block Image

3) Measured voltage on the backlight connector WITH connected backlight - on power on the voltage immediately jumps to the correct 170V, after ~400ms of stable flat 170V, it suddenly decays exponentially as if someone just cut the power to it or disabled backlight. I manage to notice backlight flash for a brief moment from the back side of the TV. After it decays, it stays at 1.3-1.5V forever. Looks like this:

Block Image

4) Measured voltage on backlight connector WITHOUT backlight cable. It overshoots target voltage and then quickly decays too. Like so

Block Image

5) There is no short circuit in the backlight itself, so it shouldn’t be some safety killswitch. Also, I would have voltage with unplugged backlight cable then, but I don’t (see 4).

6) Before I did most of these measurements, I replaced the power supply board RSAG7.820.6106 ''with another one from ebay (I thought 1.3V on backlight circuit and no short would mean power supply is dead. I was wrong.). Behavior of old and new power supply is 100% identical.

Tbh I have no clue what it is, but there isn’t actually much left. It’s not TCON board since the image is ok and it has nothing to do with backlight, then it could only be the main logic board with all the connectors, right?

Assistance would be much appreciated

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 1
Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

@ellectrician this sounds like you have some bad backlight strips. Your voltages and signals are doing what they are supposed to do. If nothing else you can get a backlight tester (since it is a PITA to replace the strips on a panel that size) or place a dummy load on the power board LED connectors and see what your board behaves like then

Bu yanıt yardımcı oldu mu?

Puan 1

Yorumlar:

thanks for the insight. However, I thought the 170V should stay stable on the LED connector both plugged in and especially if not. Am I missing something? Since it's my first TV (and I'm not expecting many more), I just ordered a replacement mainboard. With realistic expectations that it may help or it may not.

I don't understand the logic behind your conclusion tho. Why could what I presented mean dead LED? (especially since this statement contradicts most resources that state the voltage on the connector should stay high if there is no short circuit and especially if the connector is. well, disconnected from LEDs)

TV backlight tester costs 20$, ordered one too, so we'll see soon. I feel you might be right, I'm just not sure I understand why

tarafından

@ellectrician I hear you and some of that is a mystery but remember your TV knows when the backlight is out and hence produces error codes etc. It appears to have to do with the load on the line and turns of if it does not recognize any. The issues here is that it is the power board that supplies the voltage but the main board is telling it what and when to do so. unless we would have proper access to all the service manual, we sometimes just have to guess. Let us know how it works out. BTW excellent diagnostics and tools :-)

tarafından

thank you :) The main board has arrived today. Which means I've already tried new power supply board and new main board. Same bahavior. Backlight flashes for an instant and goes off. Seems your educated guess was right, there is nothing left to be bad except for the backlight itself, which I'm not sure I'm going to do (or maybe I will, you never know).

tarafından

I've had a similar issue with Dell monitors where the back light comes on briefly then turns off it turned out to be bad capacitors on the power supply, see my fixit on dell monitors

tarafından

@thuban I tried new known good power supply board first, it didn't help

tarafından

4 tane daha yorum göster

Yorum Ekle

Yanıtını ekle

Ilya sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 1

Son 30 gün: 34

Her zaman: 34