Ana içeriğe geç

Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

326 Soru Tümünü görüntüle

Looses mouse and keybord function after approx 15min running

The machine looses mouse and key functions after 15min and does not recover from it, until it is shut down. Then it is fine again for another 15 minutes…I tried of course another wired keyboard and mouse and switched USB ports, but the problem persists. Any clue where to look for the disconnect.

Update (08/16/2021)

Hi Dan, I have tried any one of the 4 ports with the same result, once the freeze occurs there is no movement. The voltage on those port is 5.09V 0.1 A after a freeze, using one of the USB voltmeters you suggested. Trying to do a time machine backup I notice that it is not only the mouse click action which fails once it freezes: The time machine backup process also stops, sitting now at 8.87GB without moving any further…I should mention also that the machine still registeres mouse movements, i.e: the curser can be moved anywhere, but it does not click or select anything anymore. I guess I will try the SSD from this iMac in another machine to see if it is a corrupt OS or if it is hardware in the machine. Also when I had tried to reset the USB hub in terminal unloading the kext, it was unable to do so. I used this command: sudo kextunload IOUSBMassStorageClass.kext .

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0

Yorumlar:

Then the logic boards PCH logic is failing.

tarafından

@danj , sure looks like it. The SSD works just fine in the other iMac, so it is not a corrupt OS. Is there any particular component I can replace on the logic board, which would typically cause this? I have a few spare lbs of that vintage, and would not mind to solder on a component of a donor board...I do not have the schematics though...

tarafından

@jurgenkoppen - Sadly its time for a new logic board. The PCH chip is the large chip under the heat sink on the back side of the board and it not really replaceable.

tarafından

Thank you so much for your help to get to the bottom of this and all the other mac problems, Dan. As usual, you rock! You make my efforts to help folks with their Maccery possible in the first place...

tarafından

The mystery continues: So I bought a logic board of Ebay, successfully installed it and proudly presented the A1311 to my buddy. He runs his admittedly very old OS 10.6.8 SSD with all the good old Final Cut Pro and Adobe programs he wants to keep on using, until it seized up again: ie: curser moves, but cannot click, no key input either, only shut down resolves it... On reboot everything is fine again, only to seize again a bit later, anywhere between 10min and 30min. So I thought maybe the OS is corrupt or the SSD faulty, and booted of an external disc with OSX10.11. It ran happily for a long time, until I engaged the internal 10.6.8 SSD in an attempt to migrate its data to the external 10.11 drive. Froze again.

tarafından

1 tane daha yorum göster

Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Which USB port are you using?

Block Image

If you are using one of the ports that also supports the BT port then you could have a bad hub. Try using the other ports. If that doesn’t help then its possible to PCH has a problem. Otherwise you could have a power issues with the USB ports, check them using a USB power meter like this one USB Mini Voltmeter then you need to look deeper in the power side.

USB Mini Voltmeter Görseli

Ürün

USB Mini Voltmeter

$9.99

Bu yanıt yardımcı oldu mu?

Puan 1
Yorum Ekle

Yanıtını ekle

Jurgen sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 0

Her zaman: 27