Ana içeriğe geç

A1708/EMC 3164 — Released June 2017, this entry-level MacBook Pro retains its traditional function keys (as opposed to the OLED Touch Bar).

477 Soru Tümünü görüntüle

New logic Board, now no battery detected

So I know this has been asked several times and it always ends up being solved by either a new battery or a new battery data cable. In my case, I have installed a new battery, no good result (still no battery detected). And I’ve also pulled a known good battery data cable from an exact match donor macbook (2017 Fn key). So I’ve installed a brand new battery and a “not new but working in another machine” data cable and still can’t get the battery to detect in this system with a new logic board.

Here I am hoping somebody may have a slightly different suggestion? I literally have no idea what else could be involved here that would be keeping the system from seeing the battery.

Odd thing is, it has twice started powering on while charger was unplugged (fan spins up and low battery warning alert on screen) and I got excited, but then after plugging the charger back in and the laptop booting, there was still a big X on the battery icon each time. I’m not sure if this matters, but after logging into the user account, the battery icon indicator in the taskbar disappears and trying to turn it on just results in the system preferences checkbox unchecking itself immediately. That could be nothing but it’s odd…

I’m dying of frustration with this stupid thing ?

Edit: adding photos of Logic board for responses below in the hopes that I’m missing something visually (bad cap,resistor etc.), everything looks ok (to me) around the detector cable and is solidly attached to pads. My iPhone 8 is surprisingly blurry when zoomed in but this was the clearest.

Block Image

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2
Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Really strange... I did get a new battery detection cable and installed it, now the battery is self-aware, or more accurately, now on speaking terms with the logic board. Seems to be working, charging, cycle counts are readable and charge levels ok.

The really strange part is, in this case, only a brand new never-installed detection cable was the solution. I actually borrowed another cable from another A1708 2017 that worked in that system also (which was the 2nd known good cable I tried), when both the donor Batt. detect cables were reinstalled to their respective systems those systems both had no issues reading battery data, at least telling me that both of those worked all along, just not in the problem system.

I don't think this means anything, there is no feasible way the cable itself can have any knowledge of being mated to a system and the cables have no chips or memory as far as I can tell. Still mystified but happy with the outcome.

But if anybody else has the issue I had, spring for a NEW $5-$10 battery detection cable to save yourself from the headaches I had.

Bu yanıt yardımcı oldu mu?

Puan 2
Yorum Ekle
En Yararlı Yanıt

There is a resistor at the top to the left of the data connector. Check it hasn’t been nudged.

Block Image

Bu yanıt yardımcı oldu mu?

Puan 3

5 Comments:

Hmmm, those components are all there and they seem solidly connected (I wiggled them gently on both lead pads and no movement at all). I can't add a picture in a comment back to you. I'm not sure if I could test these with an ESR or multi meter? I have one but am not sure what the values should look like. Thanks so much for the suggestion.

tarafından

@northamptonpc Just checked the documents I have (trying to find the value for the resistor) and I think the resistor in question is actually the one below the connector, the lone one sort of between the battery data connector and the trackpad connector. It's on the "Sys_detect" line so that would make sense to me. And if it's there and looks intact, you can definitely test with a multimeter, it's just itty bitty. But it's supposed to be a 10K resistor.

It could also be an issue with the connector itself. But in the absence of liquid damage I would not expect this to be the case.

If you want to add a picture I suggest editing your original post to include pics. :)

tarafından

@flannelist Don't know why I didn't think of that, thanks ;) Visually it looks intact and solidly attached but I know that doesn't mean it's working properly, I'm going to stick some probes on it and see. Thank you all so much, I'll update.

tarafından

Just tested the Sys_detect resistor which gave me 9.88-9.89 K ohms, I Think that is in the normal range? My next step is I've ordered a 3rd battery detect cable, this one is new, to arrive tomorrow and I'll try that, all the while praying to the great Ether Spirit for good luck.

tarafından

@imicrosoldering @flannelist Thanks again to both of you for the guidance. I'm eternally grateful :)

tarafından

Yorum Ekle

Yanıtını ekle

just chris... sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 4

Son 30 gün: 12

Her zaman: 113