Ana içeriğe geç

27" display with 2560 x 1440 pixels resolution Thunderbolt & MagSafe cable attachments

146 Soru Tümünü görüntüle

Black screen, but fan and Magsafe operational, PSU pinout tested OK

All right, so I bought a dead Thunderbolt display 27” (for 7 EUR) and I want to fix it and would appreciate any help or comments.

What works:

  • Magsafe charging works.
  • The internal fan is running, and since it’s getting power and signal from the logic board, I reckon the logic board is not entirely dead.

What doesn’t work:

The display, USB etc is not recognised by the Macbook Pro. The display does not show any kind of image. The computer doesn’t even react (i e flicker) when the TB cable is inserted/pulled out. This MBP works perfectly with other Apple displays.

My questions:

  1. Any tips on where to get hold of a Thunderbolt 2 cable to see if the internal one is bad? I don’t want to spend 25-30 EUR on a cable if that is not the issue.
  2. If anyone has a replacement glass, I am interested in buying..
  3. Is there any kind of fuses or similar safety feature that would cause the logic board to not power up?
  4. Any tips on troubleshooting the logic board further?

Update (07/25/2022)

I successfully repaired the display!

The problem was the All-in-one-cable.

I suspected the cable after visually inspecting the PSU and logic board, which looked fine. I also measured correct voltages coming from the PSU, and also seeing that the logic board spun up the fan, so it seemed to be at least somewhat functional.

The AIO cable was 25 EUR from eBay and the display now works perfectly!

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 2

Yorumlar:

Really happy to hear that you were able to solve the problem, congratulations! :D

To make it easier for others to solve the same problem, please copy the update message and post it as an answer. Then mark your answer as the solution to your problem.

tarafından

@eke0909 Thank you for showing me the ways, updated as suggested!

tarafından

Yorum Ekle

2 Cevap

Filtre ölçütü:
Seçilen Çözüm

Update (07/25/2022)

I successfully repaired the display!

The problem was the All-in-one-cable.

I suspected the cable after visually inspecting the PSU and logic board, which looked fine. I also measured correct voltages coming from the PSU, and also seeing that the logic board spun up the fan, so it seemed to be at least somewhat functional.

The AIO cable was 25 EUR from eBay and the display now works perfectly!

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

In a darkened room when you turn on the display do you see a bit of a glow? If you do that is telling us the backlight is powering up. If not then I’m suspecting you have a power supply issue as this display has two power feeds 3.3 V DC & 5.1 V DC its possible one has failed.

  • Google: LED Cinema Display 27" (A1316) Apple Technicians Guide

Which is similar to the Thunderbolt display and can be found.

Bu yanıt yardımcı oldu mu?

Puan 0
Yorum Ekle

Yanıtını ekle

olovkallgarn sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 2

Son 7 gün: 6

Son 30 gün: 15

Her zaman: 62