Ana içeriğe geç

2.26 or 2.4 GHz / White plastic unibody enclosure

645 Soru Tümünü görüntüle

My batteri wont charge

Hi,
I m trying to fix this old Macbook, I got. I have an MacBook 2012 aswell, and have two chargers, both are working with the 2012 so they shouldnt be the problem.

I bought a new battery to the mid 2010, and everything works perfectly, but the new batteri wont charge. But I can run the computer with one charger in it, that works great.
I have tried to reset the SMC, both with remove the batteri and hold down powerbutton for 10 sec, and left shift, ctrl, alt for 7 seconds and the power button for another 7 sec.
Which one is the correct way for my Computer? But none helps.
Is there anything else I can do?
Its an old drive in it so Im gonna change to SSD, and also change RAM, could that help someway? Newer OS?

Update (02/23/2022)

Block Image



Ok, this is the image.
So I bought a new battery, when i came it only had 10% battericharge, when I was gonna check coconutbattery again now, my daughter(there for the destktopimage :) ) had used the computer without a charger. The charger has a green lightning but the computer didnt start at all. I saw a youtube movie earlier where they schratched the keyboardcontact? and this worked, but the fan went realy high. However I was able to take this picture.

But now I have the startproblem to deal with aswell….

Yanıtlandı! Cevabı görüntüle Ben de bu sorunu yaşıyorum

Bu iyi bir soru mu?

Puan 0
6 Yorum

Have you checked coconutbattery to see what it’s saying about the battery?

tarafından

No, I dont even know what it is. But I will check it out, thanks. Took for granted though that there was a new battery that i should work.

tarafından

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question

tarafından

So what Im looking at. :)

Everything seems good to me.

macOS Battery status good

Loadcycles 1

Age 275 days..

However

Charging with 0 Watts

Power adapter Connected

tarafından

@Mr Magoo - Can you post the image so we can see it too!

tarafından

1 tane daha yorum göster

Yorum Ekle

1 Cevap

Filtre ölçütü:
Seçilen Çözüm

Sorry you’ve got a bad battery the micro-controller within it has failed.

Bu yanıt yardımcı oldu mu?

Puan 1

2 Yorum:

Oh.. do you see that on the image? Or how do I see that?

Do you think I can reclaim the battery and get another one?

Or what can I do with the battery now?.. just throw it?

tarafından

Your capture shows NaN and other blank data! Where there should be data.

I would contact the seller and try to get a replacement.

tarafından

Yorum Ekle

Yanıtını ekle

Mr Magoo sonsuza kadar minnettar olacak.
İstatistikleri Görüntüle:

Son 24 Saat: 0

Son 7 gün: 0

Son 30 gün: 14

Her zaman: 100